summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-11 09:31:12 +0800
committerzxp198210052023-12-11 09:31:12 +0800
commit0cd7d91031c76cb0402e23f78c2ae6db48380764 (patch)
tree3b37cc86beb7adf36d83e556d2f824ad5f301e04
parent1586deacc7632d12be26f3cddd74e9cc27bbde99 (diff)
downloadaur-0cd7d91031c76cb0402e23f78c2ae6db48380764.tar.gz
update to 2023-50
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD8
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac21db4e2e0a..03faa5a3bbb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kaiteki-bin
pkgdesc = A comfy Fediverse client for microblogging instances, made with Flutter and Dart. Currently with simple Mastodon, Pleroma, Misskey and Calckey support
- pkgver = 2023_49
+ pkgver = 2023_50
pkgrel = 1
url = https://kaiteki.app
arch = x86_64
@@ -14,8 +14,10 @@ pkgbase = kaiteki-bin
depends = pango
depends = gdk-pixbuf2
depends = fontconfig
- provides = Kaiteki
- source = kaiteki-2023_49.zip::https://github.com/Kaiteki-Fedi/Kaiteki/releases/download/weekly-2023-49/linux.zip
- sha256sums = 7cc112cc34ab295be81aa9b291fb46d143a537c925b8ed161c5d7175df52ec22
+ depends = harfbuzz
+ provides = kaiteki=2023_50
+ conflicts = kaiteki
+ source = kaiteki-2023_50.zip::https://github.com/Kaiteki-Fedi/Kaiteki/releases/download/weekly-2023-50/linux.zip
+ sha256sums = 09d0ea219d44fcb9b729e89e21b4cd4506933b756357131217df5a008294e27c
pkgname = kaiteki-bin
diff --git a/PKGBUILD b/PKGBUILD
index 006835c469c6..f374e1480372 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
# Contributor: Siavash Askari Nasr <ciavash@protonmail.com>
pkgname=kaiteki-bin
_pkgname=Kaiteki
-pkgver=2023_49
+pkgver=2023_50
pkgrel=1
pkgdesc="A comfy Fediverse client for microblogging instances, made with Flutter and Dart. Currently with simple Mastodon, Pleroma, Misskey and Calckey support"
arch=('x86_64')
url='https://kaiteki.app'
_ghurl=https://github.com/Kaiteki-Fedi/Kaiteki
license=('AGPL3')
-provides=("${_pkgname}")
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}=${pkgver}")
depends=(
'gtk3'
'libhandy'
@@ -19,6 +20,7 @@ depends=(
'pango'
'gdk-pixbuf2'
'fontconfig'
+ 'harfbuzz'
)
makedepends=(
'gendesk'
@@ -26,7 +28,7 @@ makedepends=(
source=(
"${pkgname%-bin}-${pkgver}.zip::${_ghurl}/releases/download/weekly-${pkgver//_/-}/linux.zip"
)
-sha256sums=('7cc112cc34ab295be81aa9b291fb46d143a537c925b8ed161c5d7175df52ec22')
+sha256sums=('09d0ea219d44fcb9b729e89e21b4cd4506933b756357131217df5a008294e27c')
build() {
gendesk -q -f -n --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} --no-sandbox %U"
chmod 755 "${srcdir}/linux/${pkgname%-bin}"