summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-04 09:33:55 +0800
committerzxp198210052023-12-04 09:33:55 +0800
commit1586deacc7632d12be26f3cddd74e9cc27bbde99 (patch)
treec68c02dac5b89914a5a141a9d50aea0a53df30aa
parenteac38f3c1288835f79c51caeb8fd9558bf0d7aa9 (diff)
downloadaur-1586deacc7632d12be26f3cddd74e9cc27bbde99.tar.gz
update to 2023-49
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD10
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48279210b0b3..ac21db4e2e0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kaiteki-bin
pkgdesc = A comfy Fediverse client for microblogging instances, made with Flutter and Dart. Currently with simple Mastodon, Pleroma, Misskey and Calckey support
- pkgver = 2023_47
+ pkgver = 2023_49
pkgrel = 1
url = https://kaiteki.app
arch = x86_64
@@ -15,9 +15,7 @@ pkgbase = kaiteki-bin
depends = gdk-pixbuf2
depends = fontconfig
provides = Kaiteki
- source = kaiteki-2023_47.zip::https://github.com/Kaiteki-Fedi/Kaiteki/releases/download/weekly-2023-47/linux.zip
- source = kaiteki.png::https://raw.githubusercontent.com/Kaiteki-Fedi/Kaiteki/weekly-2023-47/src/kaiteki/assets/icon.png
- sha256sums = 3e97f8c7231e4e6af52db8aab9a6f10308ce9a501add318f347e92c5b2f6d97f
- sha256sums = dc6b22558692d50f71113dbcbfed6382892cc2a27444cdacde03099297f36e3e
+ source = kaiteki-2023_49.zip::https://github.com/Kaiteki-Fedi/Kaiteki/releases/download/weekly-2023-49/linux.zip
+ sha256sums = 7cc112cc34ab295be81aa9b291fb46d143a537c925b8ed161c5d7175df52ec22
pkgname = kaiteki-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9918ec40e384..006835c469c6 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Siavash Askari Nasr <ciavash@protonmail.com>
pkgname=kaiteki-bin
_pkgname=Kaiteki
-pkgver=2023_47
+pkgver=2023_49
pkgrel=1
pkgdesc="A comfy Fediverse client for microblogging instances, made with Flutter and Dart. Currently with simple Mastodon, Pleroma, Misskey and Calckey support"
arch=('x86_64')
@@ -25,12 +25,10 @@ makedepends=(
)
source=(
"${pkgname%-bin}-${pkgver}.zip::${_ghurl}/releases/download/weekly-${pkgver//_/-}/linux.zip"
- "${pkgname%-bin}.png::https://raw.githubusercontent.com/Kaiteki-Fedi/Kaiteki/weekly-${pkgver//_/-}/src/kaiteki/assets/icon.png"
)
-sha256sums=('3e97f8c7231e4e6af52db8aab9a6f10308ce9a501add318f347e92c5b2f6d97f'
- 'dc6b22558692d50f71113dbcbfed6382892cc2a27444cdacde03099297f36e3e')
+sha256sums=('7cc112cc34ab295be81aa9b291fb46d143a537c925b8ed161c5d7175df52ec22')
build() {
- gendesk -q -f -n --categories "Network" --name="${_pkgname}" --exec="${pkgname%-bin} --no-sandbox %U"
+ gendesk -q -f -n --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} --no-sandbox %U"
chmod 755 "${srcdir}/linux/${pkgname%-bin}"
}
package() {
@@ -38,5 +36,5 @@ package() {
cp -r "${srcdir}/linux/"* "${pkgdir}/opt/${pkgname%-bin}"
ln -sf "/opt/${pkgname%-bin}/${pkgname%-bin}" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
- install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/linux/data/flutter_assets/assets/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
} \ No newline at end of file