summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSerge K2021-04-23 04:32:02 +0700
committerSerge K2021-04-23 04:32:02 +0700
commite75cf72867b21fa5742b1540f205b0e74488cd1b (patch)
tree26d312f571df9183e281a65184995ef3336be238
downloadaur-e75cf72867b21fa5742b1540f205b0e74488cd1b.tar.gz
Initial upload: kaizen 5.79.96-1
add kaizen
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE10
-rw-r--r--PKGBUILD45
-rw-r--r--kaizen.desktop10
-rw-r--r--kaizen.pngbin0 -> 9487 bytes
5 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f89bb17bfca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kaizen
+ pkgdesc = Kaizen ElasticSearch GUI
+ pkgver = 5.79.96
+ pkgrel = 1
+ url = https://www.elastic-kaizen.com/
+ arch = x86_64
+ license = custom
+ source = https://www.elastic-kaizen.com/releases/kaizen-5.79.96-linux-x64.zip
+ source = kaizen.desktop
+ source = LICENSE
+ source = kaizen.png
+ sha512sums = 9123ac7bf1fe2bef3ebeaa8d45ba2f8faee27689874e36f7ee20c9bc312082b611ae20fd542d51e132cc31ff511ca5559fcb77e1cce421af501d1c02570fc4a3
+ sha512sums = 889095694d1d5b3268242acdb5be3c9d62d608a9263e46baf311e88cffbbe21562321906eac5e2b3e12d6a094e7c122a565386a306b428db415009373d9fd80c
+ sha512sums = 35e15a34c425c8af17c1141a35cec0cbea6aba65d01443fb39ceb09ff51bb30ab356192d54b33dfb953ef9ddc6e489e42067358543f129e03f9a0c4f5a041529
+ sha512sums = a0277b72a04cfa7dad2ae8819fc5a009211bbbb44645cc1b7f73fb66e9473d47d5fa6273dfc977bd6746bc435e5ddc21ba28d3cb03e3f090ae6b5ac82137b913
+
+pkgname = kaizen
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ef5abd2711a5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,10 @@
+This End-User License Agreement ("EULA") is a legal agreement between you and artcom venture GmbH ("Vendor"). This EULA agreement governs your acquisition and use of Kaizen ("Software") directly from the Vendor.
+
+The Vendor hereby grants you a personal, non-transferable, non-exclusive licence to use the Software on your devices. You are not permitted to:
+
+- Edit, alter, modify, adapt, translate or otherwise change the whole or any part of the Software
+- Reproduce, copy, distribute, resell or otherwise use the Software for any commercial purpose
+- Allow any third party to use the Software on behalf of or for the benefit of any third party
+- Use the Software in any way which breaches any applicable local, national or international law
+
+The software is provided "as is", without warranty of any kind, express or implied, including but not limited to the warranties of merchantability, fitness for a particular purpose and non-infringement. In no event shall the authors or copyright holders be liable for any claim, damages or other liability, whether in an action of contract, tort or otherwise, arising from, out of or in connection with the software or the use or other dealings in the software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1ad59a68785
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Serge K <arch@phnx47.net>
+
+# Repository for PR: https://gitlab.com/phnx47-aur/kaizen
+
+pkgname=kaizen
+pkgdesc="Kaizen ElasticSearch GUI"
+pkgver=5.79.96
+pkgrel=1
+arch=('x86_64')
+url='https://www.elastic-kaizen.com/'
+license=('custom')
+source=("https://www.elastic-kaizen.com/releases/kaizen-${pkgver}-linux-x64.zip"
+ "kaizen.desktop"
+ "LICENSE"
+ "kaizen.png")
+
+sha512sums=('9123ac7bf1fe2bef3ebeaa8d45ba2f8faee27689874e36f7ee20c9bc312082b611ae20fd542d51e132cc31ff511ca5559fcb77e1cce421af501d1c02570fc4a3'
+ '889095694d1d5b3268242acdb5be3c9d62d608a9263e46baf311e88cffbbe21562321906eac5e2b3e12d6a094e7c122a565386a306b428db415009373d9fd80c'
+ '35e15a34c425c8af17c1141a35cec0cbea6aba65d01443fb39ceb09ff51bb30ab356192d54b33dfb953ef9ddc6e489e42067358543f129e03f9a0c4f5a041529'
+ 'a0277b72a04cfa7dad2ae8819fc5a009211bbbb44645cc1b7f73fb66e9473d47d5fa6273dfc977bd6746bc435e5ddc21ba28d3cb03e3f090ae6b5ac82137b913')
+
+build() {
+
+ # Correct kaizen.sh
+ sed -e "s/jvm/\/opt\/${pkgname}\/jvm/g" -i "$srcdir/${pkgname}.sh"
+ sed -e "s/${pkgname}.jar/\/opt\/${pkgname}\/${pkgname}.jar/g" -i "$srcdir/${pkgname}.sh"
+}
+
+package() {
+
+ install -Dm644 "$srcdir/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -dm755 "${pkgdir}/opt"
+ cp -a "${srcdir}/." "${pkgdir}/opt/${pkgname}/"
+
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+
+ # dirty hack
+ touch "${pkgdir}/usr/share/${pkgname}/licence"
+ touch "${pkgdir}/usr/share/${pkgname}/settings"
+
+ install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname}.png"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/kaizen.desktop b/kaizen.desktop
new file mode 100644
index 000000000000..aeabdcbe4470
--- /dev/null
+++ b/kaizen.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Kaizen
+Comment=Kaizen ElasticSearch GUI
+Path=/usr/share/kaizen
+Exec=./config/kaizen
+Icon=kaizen
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=Development
diff --git a/kaizen.png b/kaizen.png
new file mode 100644
index 000000000000..b8ebf97e8ef3
--- /dev/null
+++ b/kaizen.png
Binary files differ