summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Vorotnikov2016-10-31 19:17:56 +0300
committerArtem Vorotnikov2016-10-31 19:17:56 +0300
commitd0f5714b200ea89a1c552c45a46718a95c728eaf (patch)
tree63bab2773064c66cfa49bf371207449726494998
parentc8276c17f5bfd693fbefd5fb5051e22f294ef8c4 (diff)
downloadaur-d0f5714b200ea89a1c552c45a46718a95c728eaf.tar.gz
Version bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 678847c9f03d..4ee155a87fe8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Sep 13 19:10:57 UTC 2016
+# Mon Oct 31 16:17:41 UTC 2016
pkgbase = kakoune-git
pkgdesc = Code editor heavily inspired by Vim
- pkgver = r4278.6faed96
+ pkgver = r4446.650a989
pkgrel = 1
url = https://github.com/mawww/kakoune
arch = i686
@@ -16,6 +16,7 @@ pkgbase = kakoune-git
optdepends = xdotool: add support for kak windows switching (in grep, make... files)
optdepends = clang: add command for C/CPP insert mode completion support
optdepends = universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition
+ optdepends = tmux: tabbing support
source = kakoune-git::git+https://github.com/mawww/kakoune.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bd5bbd8cb931..2303ce8182e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Gokcehan Kara <gokcehankara@gmail.com>
+# Maintainer: Artem Vorotnikov <artem@vorotnikov.me>
+# Contributor: Gokcehan Kara <gokcehankara@gmail.com>
# Contributor: Guillaume ALAUX <Guillaume at ALAUX dot net>
# Contributor: Shizeeg Unadequatov <shizeeque@gmail.com>
pkgname=kakoune-git
-pkgver=r4278.6faed96
+pkgver=r4446.650a989
pkgrel=1
pkgdesc='Code editor heavily inspired by Vim'
arch=('i686' 'x86_64')
@@ -13,7 +14,8 @@ depends=('ncurses' 'boost')
optdepends=('xorg-xmessage: for nicer debugging messages'
'xdotool: add support for kak windows switching (in grep, make... files)'
'clang: add command for C/CPP insert mode completion support'
- 'universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition')
+ 'universal-ctags-git: provides `readtags` used by `:tag` command to jump on a tag definition'
+ 'tmux: tabbing support')
makedepends=('git' 'asciidoc')
source=("${pkgname}::git+https://github.com/mawww/kakoune.git")
@@ -36,6 +38,6 @@ build() {
package() {
cd "${srcdir}/${pkgname}/src"
- debug=no make install DESTDIR="${pkgdir}" PREFIX=/usr
+ debug=no make install-strip DESTDIR="${pkgdir}" PREFIX=/usr
install -D ../UNLICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}