summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoretckeeper2022-08-05 07:35:13 +0200
committeretckeeper2022-08-05 07:35:13 +0200
commit35d302d46b6f4a340bcdfdc50ef2a1a44238051d (patch)
treefae0ac421e62e8e986eaa829eab33ae6cc6aef06
parentcc71979707f5fb29eaa008d1efcc29c030d9ac0b (diff)
downloadaur-kalliope.tar.gz
forgot to add the .so lib to the symlinks
delete bogus tests dir
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58e1328621b3..febb2ce9f87f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kalliope
pkgdesc = Modular always-on voice controlled personal assistant designed for home automation
pkgver = 0.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kalliope-project/kalliope
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index f43b4acd2753..871fb74be8d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: BrainDamage
pkgname=kalliope
pkgver=0.7.2
-pkgrel=1
+pkgrel=2
arch=('any')
pkgdesc="Modular always-on voice controlled personal assistant designed for home automation"
depends=(python svox-pico-bin
@@ -46,6 +46,10 @@ package()
#replace the embedded snowboy lib with a symlink to the official package's lib
_systemSitePackages="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ find "${_systemSitePackages}/snowboy" -type f -name '_snowboydetect.*' -exec ln -sfv -t "${pkgdir}/${_systemSitePackages}/${_targetSnowboyDir}" {} \;
find "${_systemSitePackages}/snowboy" -type f -name 'snowboydetect.*' -exec ln -sfv -t "${pkgdir}/${_systemSitePackages}/${_targetSnowboyDir}" {} \;
ln -sv -t "${pkgdir}/${_systemSitePackages}/${_targetSnowboyDir}" "${_systemSitePackages}/snowboy/resources"
+
+ #delete the bogus tests dir
+ find "${pkgdir}/${_systemSitePackages}/Tests" -delete
}