summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2018-02-10 18:22:47 +0100
committerMichel Zou2018-02-10 18:22:47 +0100
commit3171e2ab4276474dc46f0e54d9177b8298e149fc (patch)
tree6bbd8a1fe5ab38f1f5a850df0f2bfdab274dfa07
parentc95e0c76074e7fc3d5e992789b01fd01dd6fd776 (diff)
downloadaur-3171e2ab4276474dc46f0e54d9177b8298e149fc.tar.gz
0.5.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 31 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f5da8c0bb4b..d7d4ab5e62be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Fri Sep 1 13:37:57 UTC 2017
+# Sat Feb 10 17:22:47 UTC 2018
pkgbase = kalliope
pkgdesc = Modular always-on voice controlled personal assistant designed for home automation
- pkgver = 0.4.5
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/kalliope-project/kalliope
- arch = i686
arch = x86_64
license = MIT
+ makedepends = swig
depends = portaudio
depends = python-speechrecognition
depends = python-markupsafe
@@ -32,8 +32,10 @@ pkgbase = kalliope
depends = python-soundfile
depends = python-sounddevice
depends = python-sox
- source = https://github.com/kalliope-project/kalliope/archive/v0.4.5.tar.gz
- sha256sums = 8931e1ff865f2cd926183818c5a20d603d9c3cc222f1c1c3f8c72e6b3bbfee75
+ depends = python-voicerss-tts
+ depends = python-paho-mqtt
+ source = https://github.com/kalliope-project/kalliope/archive/v0.5.0.tar.gz
+ sha256sums = e4e1930a6cbacd4b6c28f41a4c7a900c25deb0951c9de8716becffef4e329fe0
pkgname = kalliope
diff --git a/PKGBUILD b/PKGBUILD
index a75e2abfb771..91011f6e1135 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,33 @@
pkgname=kalliope
-pkgver=0.4.5
+pkgver=0.5.0
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('x86_64')
pkgdesc="Modular always-on voice controlled personal assistant designed for home automation"
-depends=(portaudio python-speechrecognition python-markupsafe python-pyaudio python-pythondialog python-jinja python-cffi python-flask-restful python-ipaddress python-apscheduler python-flask-testing python-httpretty python-requests svox-pico-bin mplayer python-feedparser python-mock python-transitions python-gitpython python-pyalsaaudio python-rpi.gpio python-soundfile python-sounddevice python-sox)
+makedepends=(swig)
+depends=(portaudio python-speechrecognition python-markupsafe python-pyaudio python-pythondialog python-jinja python-cffi python-flask-restful python-ipaddress python-apscheduler python-flask-testing python-httpretty python-requests svox-pico-bin mplayer python-feedparser python-mock python-transitions python-gitpython python-pyalsaaudio python-rpi.gpio python-soundfile python-sounddevice python-sox python-voicerss-tts python-paho-mqtt)
license=('MIT')
url="https://github.com/kalliope-project/kalliope"
source=("https://github.com/kalliope-project/kalliope/archive/v${pkgver}.tar.gz")
-sha256sums=('8931e1ff865f2cd926183818c5a20d603d9c3cc222f1c1c3f8c72e6b3bbfee75')
+sha256sums=('e4e1930a6cbacd4b6c28f41a4c7a900c25deb0951c9de8716becffef4e329fe0')
+
+prepare()
+{
+ cd "$srcdir/kalliope-${pkgver}"
+ sed -i "s|jinja2>=2.8,<=2.9.6|jinja2>=2.8|g" setup.py
+ sed -i "s|ansible>=2.3,<2.4|ansible>=2.3|g" setup.py
+
+ # rebuild snowboy
+ SNOWBOY_VERSION=1.2.0
+ wget -c https://github.com/Kitt-AI/snowboy/archive/v${SNOWBOY_VERSION}.tar.gz
+ rm -rf snowboy-${SNOWBOY_VERSION}
+ tar xzf v${SNOWBOY_VERSION}.tar.gz
+ cd snowboy-${SNOWBOY_VERSION}/swig/Python
+ sed -i "s|-lf77blas -lcblas -llapack_atlas -latlas|-lcblas|g" Makefile
+ make
+ python -c "import _snowboydetect; print('OK')"
+ cd ../../..
+ cp ./snowboy-1.2.0/swig/Python/_snowboydetect.so ./kalliope/trigger/snowboy/x86_64/python36/
+}
build()