summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2016-12-19 11:24:41 +0100
committerMichel Zou2016-12-19 11:24:41 +0100
commit4c236034f51502efe29e5100f529dadf4c0de640 (patch)
tree76fcbd348019a76a7db00a066e7abd2ae3a57d6c
downloadaur-4c236034f51502efe29e5100f529dadf4c0de640.tar.gz
0.3
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD28
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bfa1eba4c7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+# Generated by mksrcinfo v8
+# Mon Dec 19 10:24:41 UTC 2016
+pkgbase = kalliope
+ pkgdesc = Modular always-on voice controlled personal assistant designed for home automation
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/kalliope-project/kalliope
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = portaudio
+ depends = python2-speechrecognition
+ depends = python2-markupsafe
+ depends = python2-pyaudio
+ depends = python2-pythondialog
+ depends = python2-jinja
+ depends = python2-cffi
+ depends = python2-flask-restful
+ depends = python2-wikipedia
+ depends = python2-pygmail
+ depends = python2-twitter
+ depends = python2-ipaddress
+ depends = python2-wakeonlan
+ depends = python2-apscheduler
+ depends = python2-flask-testing
+ depends = python2-httpretty
+ depends = python2-requests
+ source = https://github.com/kalliope-project/kalliope/archive/v0.3.0.tar.gz
+ sha256sums = 7ddea6e381917f4f8c9a9984d393c997dbc8345dd58a377f63337cb0739416dc
+
+pkgname = kalliope
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42f2a3a2ee78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=kalliope
+pkgver=0.3.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Modular always-on voice controlled personal assistant designed for home automation"
+depends=(portaudio python2-speechrecognition python2-markupsafe python2-pyaudio python2-pythondialog python2-jinja python2-cffi python2-flask-restful python2-wikipedia python2-pygmail python2-twitter python2-ipaddress python2-wakeonlan python2-apscheduler python2-flask-testing python2-httpretty python2-requests)
+license=('MIT')
+url="https://github.com/kalliope-project/kalliope"
+source=("https://github.com/kalliope-project/kalliope/archive/v${pkgver}.tar.gz")
+sha256sums=('7ddea6e381917f4f8c9a9984d393c997dbc8345dd58a377f63337cb0739416dc')
+
+prepare() {
+ cd "$srcdir/kalliope-${pkgver}"
+ # https://github.com/kalliope-project/kalliope/pull/147
+ sed -i "s|requests==2.12.1|requests==2.12.4|g" setup.py
+}
+
+build()
+{
+ cd "$srcdir/kalliope-${pkgver}"
+ python2 setup.py build
+}
+
+package()
+{
+ cd "$srcdir/kalliope-${pkgver}"
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}