summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-11-24 22:45:43 +0100
committerMichel Zou2019-11-24 22:45:43 +0100
commit55d53f094d649209fe6438771169f33fe6217956 (patch)
tree92ec4067feaf811df71f4c677e3eae57b51aea47
parenteee572ea0dc156d2a4b0bfc18c48af0171fd5c90 (diff)
downloadaur-55d53f094d649209fe6438771169f33fe6217956.tar.gz
snowboy
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD27
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64ee86c1676c..3aaa581af8b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = kalliope
url = https://github.com/kalliope-project/kalliope
arch = x86_64
license = MIT
+ makedepends = swig
depends = portaudio
depends = python-markupsafe
depends = python-pyaudio
diff --git a/PKGBUILD b/PKGBUILD
index 4ffc722f0158..4f38a7c989ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgver=0.5.5
pkgrel=1
arch=('x86_64')
pkgdesc="Modular always-on voice controlled personal assistant designed for home automation"
-# makedepends=('swig' 'wget')
+makedepends=('swig')
depends=(portaudio python-markupsafe python-pyaudio python-pythondialog python-jinja python-cffi python-flask-restful python-ipaddress python-apscheduler python-flask-testing python-httpretty python-requests svox-pico-bin mplayer python-feedparser python-mock python-transitions python-gitpython python-pyalsaaudio python-soundfile python-sounddevice python-sox python-voicerss-tts python-paho-mqtt python-ansible python-cachingutil python-pip cblas python-gevent python-gtts python-sox python-speechrecognition python-configurationutil python-stateutil python-ruamel-yaml python-logging-tree python-classutils python-uiutil python-tableutil python-conversionutil python-openpyxl)
license=('MIT')
url="https://github.com/kalliope-project/kalliope"
@@ -14,18 +14,6 @@ prepare()
{
cd "$srcdir/kalliope-${pkgver}"
sed -i "s|ansible>=2.8.1,<2.9|ansible>=2.8|g" setup.py
-
- # rebuild snowboy
-# SNOWBOY_VERSION=1.2.0
-# wget -c https://github.com/Kitt-AI/snowboy/archive/v${SNOWBOY_VERSION}.tar.gz
-# rm -rf snowboy-${SNOWBOY_VERSION}
-# tar xzf v${SNOWBOY_VERSION}.tar.gz
-# cd snowboy-${SNOWBOY_VERSION}/swig/Python
-# sed -i "s|-lf77blas -lcblas -llapack_atlas -latlas|-lcblas|g" Makefile
-# make
-# python -c "import _snowboydetect; print('OK')"
-# cd ../../..
-# cp ./snowboy-1.2.0/swig/Python/_snowboydetect.so ./kalliope/trigger/snowboy/x86_64/python36/
}
@@ -33,6 +21,19 @@ build()
{
cd "$srcdir/kalliope-${pkgver}"
python setup.py build
+
+ # rebuild snowboy
+ SNOWBOY_VERSION=1.3.0
+ curl -fSsLO https://github.com/Kitt-AI/snowboy/archive/v${SNOWBOY_VERSION}.tar.gz
+ rm -rf snowboy-${SNOWBOY_VERSION}
+ tar xzf v${SNOWBOY_VERSION}.tar.gz
+ cd snowboy-${SNOWBOY_VERSION}/swig/Python
+ sed -i "s|-lf77blas -lcblas -llapack -latlas|-lcblas|g" Makefile
+ make
+ python -c "import _snowboydetect; print('OK')"
+ cd ../../..
+ mkdir -p ./build/lib/kalliope/trigger/snowboy/x86_64/python38/
+ cp ./snowboy-${SNOWBOY_VERSION}/swig/Python/_snowboydetect.so ./build/lib/kalliope/trigger/snowboy/x86_64/python38/
}
package()