summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-12-19 11:53:27 +0100
committerPhilipp A2021-12-19 11:53:27 +0100
commit1e91f1c4fe2d4610c68a618102e0b7896ec47927 (patch)
tree63fb673f2624094749d77bb879e6b8fd9c5cfb93
parent8b66ebb8e87bb1facb991d06e3231324ce838e13 (diff)
downloadaur-1e91f1c4fe2d4610c68a618102e0b7896ec47927.tar.gz
fix build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD29
2 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1817fbfe338..4d19f36e4b52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kallisto
pkgdesc = Quantify abundances of transcripts from RNA-Seq data
pkgver = 0.46.2
- pkgrel = 1
+ pkgrel = 2
url = http://pachterlab.github.io/kallisto/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 6e3290837789..49a05b749bf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=kallisto
pkgver=0.46.2
-pkgrel=1
+pkgrel=2
pkgdesc='Quantify abundances of transcripts from RNA-Seq data'
url="http://pachterlab.github.io/$pkgname/"
license=(BSD)
@@ -10,19 +10,34 @@ makedepends=(cmake autoconf automake)
source=("https://github.com/pachterlab/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('c447ca8ddc40fcbd7d877d7c868bc8b72807aa8823a8a8d659e19bdd515baaf2')
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # https://github.com/pachterlab/kallisto/issues/303#issuecomment-884612169
+ pushd ext/htslib
+ sed -i '/AC_PROG_CC/a \
+AC_CANONICAL_HOST \
+AC_PROG_INSTALL \
+' configure.ac
+ autoreconf -i
+ autoheader
+ autoconf
+ popd
+
+ # add missing header
+ sed -i '/#include <algorithm>/a #include <limits>' src/MinCollector.cpp
+}
+
build() {
- (
- cd "$srcdir/$pkgname-$pkgver/ext/htslib"
- autoreconf
- )
+ cd "$srcdir/$pkgname-$pkgver"
rm -rf build
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" "$srcdir/$pkgname-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" ..
make
}
package() {
- cd build
+ cd "$srcdir/$pkgname-$pkgver/build"
make install
}