summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2015-08-04 13:28:48 +0200
committerPhilipp A2015-08-04 13:28:48 +0200
commit2126ff3a51ed17775f83ae12ebb1c0eb401f7d71 (patch)
treeb2b9ef569f497a49b1d95528a16660168969a7fb
downloadaur-2126ff3a51ed17775f83ae12ebb1c0eb401f7d71.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..476e49719056
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kallisto
+ pkgver = 0.42.2.1
+ pkgrel = 1
+ url = http://pachterlab.github.io/kallisto/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = hdf5
+ makedepends = zlib
+ makedepends = cmake
+ source = https://github.com/pachterlab/kallisto/archive/v0.42.2.1.tar.gz
+ md5sums = 51b9c71d614ed756953321518648849e
+
+pkgname = kallisto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32c9fcdf1196
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=kallisto
+pkgver=0.42.2.1
+pkgrel=1
+description='Quantify abundances of transcripts from RNA-Seq data'
+url="http://pachterlab.github.io/$pkgname/"
+license=(BSD)
+arch=(i686 x86_64)
+makedepends=(hdf5 zlib cmake)
+source=("https://github.com/pachterlab/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('51b9c71d614ed756953321518648849e')
+
+build() {
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX:PATH="$pkgdir/usr" "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd build
+ make install
+} \ No newline at end of file