summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjjacky2012-02-14 17:06:00 +0100
committerOlivier Brunel2015-06-08 18:54:18 +0200
commit57188eadcb63a5c1209562717ca3f04577d6fb31 (patch)
tree441fcf9dd9e977ce3af9697fc5e99e89acbcbc39
parent469471ed1b11a0e86bcdf471c409c1f7da97b906 (diff)
downloadaur-57188eadcb63a5c1209562717ca3f04577d6fb31.tar.gz
kalu: no more source(), instead use wget & tar in build() to always get the tip. because this is dev/beta.
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17bf36de04ad..deefbdd8c964 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = kalu
- pkgdesc = Keep Arch Linux Up-to-date -- an upgrade notifier for Arch Linux
+ pkgdesc = Keep Arch Linux Up-to-date -- an upgrade notifier for Arch Linux [BETA]
pkgver = 0.0.0
pkgrel = 1
url = https://bitbucket.org/jjacky/kalu
@@ -13,8 +13,6 @@ pkgbase = kalu
depends = pacman>=4.0.1
depends = curl
depends = libnotify
- source = https://bitbucket.org/jjacky/kalu/get/tip.tar.gz
- md5sums = 6b0a05da61492e7957d728cbce695ec8
pkgname = kalu
diff --git a/PKGBUILD b/PKGBUILD
index 3d1bc8c0e588..bb2ff96fc4d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,22 @@
pkgname=kalu
pkgver=0.0.0
pkgrel=1
-pkgdesc="Keep Arch Linux Up-to-date -- an upgrade notifier for Arch Linux"
+pkgdesc="Keep Arch Linux Up-to-date -- an upgrade notifier for Arch Linux [BETA]"
arch=('i686' 'x86_64')
url="https://bitbucket.org/jjacky/kalu"
license=('GPL3+')
depends=('dbus' 'polkit' 'gtk3' 'pacman>=4.0.1' 'curl' 'libnotify')
makedepends=('pkg-config')
#source=(https://bitbucket.org/jjacky/$pkgname/get/$pkgver.tar.gz)
-source=(https://bitbucket.org/jjacky/$pkgname/get/tip.tar.gz)
+#md5sums=()
build() {
cd "$srcdir"
+
+ # download & extract tip
+ wget https://bitbucket.org/jjacky/$pkgname/get/tip.tar.gz
+ tar xzf tip.tar.gz
+
# archive is auto-generated by bitbucket, so name includes last commit
_dir=$(ls | grep jjacky-$pkgname-)
# moving it all in srcdir
@@ -28,6 +33,4 @@ package() {
make DESTDIR="$pkgdir/" install
}
-md5sums=('6b0a05da61492e7957d728cbce695ec8')
-
# vim:set ts=2 sw=2 et: