summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-07-20 21:59:10 +0200
committerDaniel Peukert2020-07-20 21:59:10 +0200
commitdf986f186f6f20aba88ef7c2390aa8909b476487 (patch)
tree7036acb0a27b3773f29639ca0895adb347af48e5
parentb921ddab7f842354a0138ef9457bb2451af95d5f (diff)
downloadaur-df986f186f6f20aba88ef7c2390aa8909b476487.tar.gz
Added kalu-cli
-rw-r--r--.SRCINFO22
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD53
-rw-r--r--gcc10.patch31
5 files changed, 100 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffc32d6085d7..86acabace325 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,26 @@
pkgbase = kalu-cli
- pkgdesc = Upgrade notifier w/ AUR support, watched (AUR) packages, news (CLI only)
+ pkgdesc = Upgrade notifier w/ AUR support, watched (AUR) packages, news - CLI only
pkgver = 4.3.0
- pkgrel = 5
+ pkgrel = 6
url = https://jjacky.com/kalu
- arch = i686
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL3
- depends = pacman>=5.1
- depends = pacman<5.2
+ makedepends = perl
+ makedepends = groff
depends = curl
depends = glib2
+ depends = pacman>=5.2
+ depends = pacman<5.3
+ provides = kalu
conflicts = kalu
- source = https://jjacky.com/kalu/kalu-4.3.0.tar.xz
+ source = kalu-cli-4.3.0-6.tar.xz::https://jjacky.com/kalu/kalu-4.3.0.tar.xz
+ source = gcc10.patch
sha256sums = 83c886e832c29768b0b80e0ee463ca057eae1a3511d2b8babdc8d6347f02cb5a
+ sha256sums = ae757c2e2e701e202818916712f87c56bfada06b8832a292505170f51bba7bbd
pkgname = kalu-cli
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index f03fdfec367a..743e91e029ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,40 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
-# This package is forked from aur/kalu. Original contributors are:
-# Contributor: jjacky
-
-_pkgname=kalu
-pkgname=$_pkgname-cli
-pkgver=4.3.0
-pkgrel=5
-pkgdesc="Upgrade notifier w/ AUR support, watched (AUR) packages, news (CLI only)"
-arch=('i686' 'x86_64')
-url="https://jjacky.com/kalu"
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: lilac <lilac@build.archlinuxcn.org>
+# Contributor: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor: jjacky (kalu PKGBUILD)
+_pkgname='kalu'
+pkgname="$_pkgname-cli"
+pkgver='4.3.0'
+pkgrel='6'
+pkgdesc='Upgrade notifier w/ AUR support, watched (AUR) packages, news - CLI only'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://jjacky.com/$_pkgname"
license=('GPL3')
-depends=('pacman>=5.1' 'pacman<5.2' 'curl' 'glib2')
-source=(https://jjacky.com/$_pkgname/$_pkgname-$pkgver.tar.xz)
-sha256sums=('83c886e832c29768b0b80e0ee463ca057eae1a3511d2b8babdc8d6347f02cb5a')
+depends=('curl' 'glib2' 'pacman>=5.2' 'pacman<5.3')
+makedepends=('perl' 'groff')
+provides=("$_pkgname")
conflicts=("$_pkgname")
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.xz::https://jjacky.com/$_pkgname/$_pkgname-$pkgver.tar.xz"
+ 'gcc10.patch'
+)
+sha256sums=('83c886e832c29768b0b80e0ee463ca057eae1a3511d2b8babdc8d6347f02cb5a'
+ 'ae757c2e2e701e202818916712f87c56bfada06b8832a292505170f51bba7bbd')
+
+_sourcedirectory="$_pkgname-$pkgver"
+
+prepare() {
+ cd "$srcdir/$_sourcedirectory/"
+ patch --forward -p1 < "$srcdir/gcc10.patch"
+}
build() {
- cd $_pkgname-$pkgver
- ./configure --prefix=/usr --disable-gui
- make
+ cd "$srcdir/$_sourcedirectory/"
+ ./configure --prefix '/usr' --disable-gui
+ make
}
package() {
- cd $_pkgname-$pkgver
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/$_sourcedirectory/"
+ make DESTDIR="$pkgdir/" install
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/gcc10.patch b/gcc10.patch
new file mode 100644
index 000000000000..9f5b09a7b82f
--- /dev/null
+++ b/gcc10.patch
@@ -0,0 +1,31 @@
+diff --git a/src/kalu/kalu.h b/src/kalu/kalu.h
+index 428aea1..1e109d8 100644
+--- a/src/kalu/kalu.h
++++ b/src/kalu/kalu.h
+@@ -134,7 +134,7 @@ typedef enum {
+ } tpl_t;
+
+ /* template names in config (prefixed w/ "template-") */
+-const gchar *tpl_names[_NB_TPL];
++extern const gchar *tpl_names[_NB_TPL];
+
+ typedef enum {
+ FLD_TITLE,
+@@ -144,7 +144,7 @@ typedef enum {
+ } fld_t;
+
+ /* field names in config */
+-const gchar *fld_names[_NB_FLD];
++extern const gchar *fld_names[_NB_FLD];
+
+ typedef enum {
+ TPL_SCE_UNDEFINED = 0,
+@@ -156,7 +156,7 @@ typedef enum {
+ } tpl_sce_t;
+
+ /* source names in config */
+-const gchar *tpl_sce_names[_NB_TPL_SCE];
++extern const gchar *tpl_sce_names[_NB_TPL_SCE];
+
+ struct field {
+ const char *def;