summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2019-01-21 11:17:14 +0100
committerAchilleas Pipinellis2019-01-21 11:17:14 +0100
commit0378aa32e1e9f57775d153c6833c0466a8b6705b (patch)
tree7f931c1d60f57ead5941f8c4ed265cbf12687679
parentced17b522d7cddb690aadf2d6bd497dfe93e8245 (diff)
downloadaur-0378aa32e1e9f57775d153c6833c0466a8b6705b.tar.gz
Update to 0.16
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
3 files changed, 12 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b513d5d11f37..cd0c75e7e3a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = kamaki
pkgdesc = A command-line tool for managing clouds
- pkgver = 0.13
- pkgrel = 3
- url = http://code.grnet.gr/projects/kamaki
- changelog = Changelog
+ pkgver = 0.16
+ pkgrel = 1
+ url = https://github.com/grnet/kamaki
arch = any
license = BSD
makedepends = python2-distribute
@@ -13,10 +12,8 @@ pkgbase = kamaki
depends = python2-dateutil
depends = astakosclient
optdepends = python2-ansicolors: for color support
- source = https://pypi.python.org/packages/source/k/kamaki/kamaki-0.13.tar.gz
- source = ca_certificates.patch
- md5sums = ad3d9a2e9398534b70012809b97fd6c5
- md5sums = 34afd4f5b468a23fcf6a99bf947b8f71
+ source = https://pypi.python.org/packages/source/k/kamaki/kamaki-0.16.tar.gz
+ sha512sums = fa336a199b63580d1a773129f6cf4287d6f547307bb2123a2f5c8710c066a2f2432288bc47b09601941c79d6c721de888f80aea9a1936f207e1e51b500d8add5
pkgname = kamaki
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
index 800187974a14..273ade1be6fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,21 @@
-# Maintainer: Achilleas Pipinellis <axilleas@archlinux.info>
+# Maintainer: Achilleas Pipinellis <axil archlinux gr>
pkgname=kamaki
-pkgver=0.13
-pkgrel=3
+pkgver=0.16
+pkgrel=1
pkgdesc="A command-line tool for managing clouds"
arch=(any)
-url="http://code.grnet.gr/projects/kamaki"
+url="https://github.com/grnet/kamaki"
license=('BSD')
-changelog=Changelog
depends=('python2-objpool' 'python2-progress' 'python2-dateutil' 'astakosclient')
makedepends=('python2-distribute' 'python2-sphinx')
optdepends=('python2-ansicolors: for color support')
-source=("https://pypi.python.org/packages/source/k/$pkgname/$pkgname-$pkgver.tar.gz"
- ca_certificates.patch )
-
-prepare() {
- # Patch ca-certificates
- # https://github.com/grnet/kamaki/commit/7e55787ac56a3169f36001ca837537eef4af42f1
- cd "$srcdir/$pkgname-$pkgver/$pkgname"
- patch -Np2 -i ../../ca_certificates.patch
-}
+source=("https://pypi.python.org/packages/source/k/$pkgname/$pkgname-$pkgver.tar.gz")
package() {
cd "$srcdir/$pkgname-$pkgver"
python2 setup.py install --root="$pkgdir" -O1
install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 Changelog "$pkgdir/usr/share/$pkgname/ChangeLog"
# Build documentation and man page
cd "$srcdir/$pkgname-$pkgver/docs"
@@ -36,6 +26,4 @@ package() {
install -Dm644 _build/man/*.1 "$pkgdir/usr/share/man/man1/"
cp -r _build/html/ "$pkgdir/usr/share/docs/$pkgname/html"
}
-
-md5sums=('ad3d9a2e9398534b70012809b97fd6c5'
- '34afd4f5b468a23fcf6a99bf947b8f71')
+sha512sums=('fa336a199b63580d1a773129f6cf4287d6f547307bb2123a2f5c8710c066a2f2432288bc47b09601941c79d6c721de888f80aea9a1936f207e1e51b500d8add5')