summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchilleas Pipinellis2015-06-10 09:15:13 +0300
committerAchilleas Pipinellis2015-06-10 09:15:13 +0300
commitced17b522d7cddb690aadf2d6bd497dfe93e8245 (patch)
tree404e7c45192de0d1e377c2b459e672070a0fe2bc
downloadaur-ced17b522d7cddb690aadf2d6bd497dfe93e8245.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--Changelog73
-rw-r--r--PKGBUILD41
-rw-r--r--ca_certificates.patch9
4 files changed, 145 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b513d5d11f37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kamaki
+ pkgdesc = A command-line tool for managing clouds
+ pkgver = 0.13
+ pkgrel = 3
+ url = http://code.grnet.gr/projects/kamaki
+ changelog = Changelog
+ arch = any
+ license = BSD
+ makedepends = python2-distribute
+ makedepends = python2-sphinx
+ depends = python2-objpool
+ depends = python2-progress
+ depends = python2-dateutil
+ depends = astakosclient
+ optdepends = python2-ansicolors: for color support
+ source = https://pypi.python.org/packages/source/k/kamaki/kamaki-0.13.tar.gz
+ source = ca_certificates.patch
+ md5sums = ad3d9a2e9398534b70012809b97fd6c5
+ md5sums = 34afd4f5b468a23fcf6a99bf947b8f71
+
+pkgname = kamaki
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..63599ed12e59
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,73 @@
+.. _Changelog:
+
+Unified Changelog file for Kamaki versions >= 0.13
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
+.. _Changelog-0.13:
+
+v0.13
+=====
+
+Released: Tue Nov 18 11:13:58 EET 2014
+
+Features
+--------
+
+* Name and Type filters in endpoint list
+* In image register, meta gets same sharing as image
+* Allow image register to auto-resolve remote path from local file
+* Merge ClientError and AstakosClientException --> AstakosClientError
+* Restore kamaki file publish/unpublish
+* Accept username or UUID in kamaki file --account/--to-account
+* History has now a buffer limit
+* Slice notation in history show
+* Datetime support in DateArgument
+* Resources can be reassigned to projects
+* Update account API commands to reflect changes in synnefo 0.16
+* Implement a get_endpoint_url method and use it
+* Rename kamaki.clients.Client.base_url --> endpoint_url, keep BW compatibility
+* Remove deprecated --hard argument in "kamaki server reboot"
+* Modify upload and download command semantics, to be more intuitive
+* Implement more console types (vnc-ws and vnc-wss)
+* Support secure HTTP connections with SSL [grnet/kamaki#54]
+
+Support
+-------
+
+* Adjust project commands to project_API changes
+* Add "dateutils" to dependencies
+* Rename packages, classes and objects to conform to pep8 standards
+* Use the term "project_id" instead of "project" everywhere in kamaki.clients
+* Update library documentation with examples [grnet/kamaki#49]
+
+
+Bug Fixes
+---------
+
+* Register image with upload but no metafile
+* Minor typos and updates in command help messages
+* All URL-related params are now URL-encoded
+* In file list, show all directories as directories
+* Do not let file-* cmds to create containers
+* Fix unicode-related bugs in error reporting
+* Modify HTTP logs and console output to escape control characters
+ [grnet/kamaki#32]
+* Fix bug of incorrectly suppressed errors in "kamaki network create"
+ [grnet/kamaki#56]
+* Set a default logger to LoggedAstakosClient [grnet/kamaki#58]
+* Show the correct name when switching kamaki users
+ [grnet/kamaki#66]
+* Fix Python 2.6 compatibility concerning HTTPS arguments
+ [grnet/kamaki#73]
+* Fix Python 2.6 compatibility concerning encode parameters
+* Rename "raise_ssl_errors" to "ignore_ssl" in HTTPConnection class
+ [grnet/kamaki#74]
+* Warn or raise errors when the configuration file is inaccessible
+ [grnet/kamaki#71]
+* Handle non-ascii characters when managing configuration options
+ [grnet/kamaki#76]
+* Handle SSL unicode bug with grace [grnet/kamaki#67]
+* Check server status before changing it [grnet/kamaki#57]
+* Fix format of "create_volume" return values
+* Support old history files [grnet/kamaki#80]
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..800187974a14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Achilleas Pipinellis <axilleas@archlinux.info>
+
+pkgname=kamaki
+pkgver=0.13
+pkgrel=3
+pkgdesc="A command-line tool for managing clouds"
+arch=(any)
+url="http://code.grnet.gr/projects/kamaki"
+license=('BSD')
+changelog=Changelog
+depends=('python2-objpool' 'python2-progress' 'python2-dateutil' 'astakosclient')
+makedepends=('python2-distribute' 'python2-sphinx')
+optdepends=('python2-ansicolors: for color support')
+source=("https://pypi.python.org/packages/source/k/$pkgname/$pkgname-$pkgver.tar.gz"
+ ca_certificates.patch )
+
+prepare() {
+ # Patch ca-certificates
+ # https://github.com/grnet/kamaki/commit/7e55787ac56a3169f36001ca837537eef4af42f1
+ cd "$srcdir/$pkgname-$pkgver/$pkgname"
+ patch -Np2 -i ../../ca_certificates.patch
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" -O1
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 Changelog "$pkgdir/usr/share/$pkgname/ChangeLog"
+
+ # Build documentation and man page
+ cd "$srcdir/$pkgname-$pkgver/docs"
+ sed -i 's/sphinx-build/sphinx-build2/' Makefile
+ make html && make man && rm -rf "_build/html/man" && rm -rf _build/doctrees
+
+ mkdir -p "$pkgdir"/usr/share/{man/man1,docs/"$pkgname"}
+ install -Dm644 _build/man/*.1 "$pkgdir/usr/share/man/man1/"
+ cp -r _build/html/ "$pkgdir/usr/share/docs/$pkgname/html"
+}
+
+md5sums=('ad3d9a2e9398534b70012809b97fd6c5'
+ '34afd4f5b468a23fcf6a99bf947b8f71')
diff --git a/ca_certificates.patch b/ca_certificates.patch
new file mode 100644
index 000000000000..ca7a7f17fab4
--- /dev/null
+++ b/ca_certificates.patch
@@ -0,0 +1,9 @@
+Index: kamaki/kamaki/defaults.py
+===================================================================
+--- kamaki.orig/kamaki/defaults.py 2014-10-03 17:21:42.000000000 +0300
++++ kamaki/kamaki/defaults.py 2014-10-03 17:25:31.000000000 +0300
+@@ -39,3 +39,4 @@
+ CACERTS_DEFAULT_PATH = None
+
+ # To overwrite any of the above, append new assignments bellow
++CACERTS_DEFAULT_PATH = '/etc/ssl/certs/ca-certificates.crt'