summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWalter Dworak2016-03-09 16:21:31 -0600
committerWalter Dworak2016-03-09 16:21:31 -0600
commitb104fd354d865eafbabb7967144bba3a3b4f009d (patch)
tree5d276d3761b9cfff2d10f79b978167eb8543298b
parentcb4f35934820afc82e5140514c45f64ae00d9eca (diff)
downloadaur-b104fd354d865eafbabb7967144bba3a3b4f009d.tar.gz
Added nginx config examples
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--kanboard-nginx-subdir.conf40
-rw-r--r--kanboard-nginx.conf35
-rw-r--r--kanboard.install2
5 files changed, 85 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f1f7afa2716..13d95a4f4e40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Feb 25 03:25:33 UTC 2016
+# Wed Mar 9 22:20:03 UTC 2016
pkgbase = kanboard
pkgdesc = Simple visual task board
pkgver = 1.0.25
- pkgrel = 4
+ pkgrel = 5
url = http://kanboard.net/
install = kanboard.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 3901cc998f4d..47747f174e57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=kanboard
pkgver=1.0.25
-pkgrel=4
+pkgrel=5
pkgdesc='Simple visual task board'
arch=('any')
url='http://kanboard.net/'
@@ -14,12 +14,16 @@ install="$pkgname.install"
options=(!strip)
source=("http://kanboard.net/kanboard-$pkgver.zip"
"kanboard-apache.conf"
+ "kanboard-nginx.conf"
+ "kanboard-nginx-subdir.conf"
"kanboard-cron")
package() {
mkdir -p ${pkgdir}/usr/share/webapps
cp -R ${srcdir}/${pkgname} ${pkgdir}/usr/share/webapps/${pkgname}
install -D "${srcdir}/kanboard-apache.conf" ${pkgdir}/etc/webapps/${pkgname}/kanboard-apache.conf
+ install -D "${srcdir}/kanboard-nginx.conf" ${pkgdir}/etc/webapps/${pkgname}/kanboard-nginx.conf
+ install -D "${srcdir}/kanboard-nginx-subdir.conf" ${pkgdir}/etc/webapps/${pkgname}/kanboard-nginx-subdir.conf
install -D "${srcdir}/kanboard-cron" ${pkgdir}/etc/webapps/${pkgname}/kanboard-cron
cp ${pkgdir}/usr/share/webapps/${pkgname}/config.default.php ${pkgdir}/etc/webapps/${pkgname}/config.php
ln -s /etc/webapps/${pkgname}/config.php ${pkgdir}/usr/share/webapps/${pkgname}/config.php
@@ -27,4 +31,6 @@ package() {
sha256sums=('c8fecf3838864ffa73f57e5bba52449ed1aa15052bfa196f07bd27a071190239'
'6eb379e74f744d95a930c90ae7744cb8236501bdcd24c7efb6a2eaf1a857204f'
+ '62853c973e5b0718ceae5dbeb76b478bb218ce89d732e66a5eef1c7c258ea4b4'
+ '892fdd22c1a2dca16ab4cab54f39cb09742d4ccde1a4a5673627e5a523969483'
'c777fe8364ca82db7956e665b8b700739b352fe4043869c33dc8ef788e3b1822')
diff --git a/kanboard-nginx-subdir.conf b/kanboard-nginx-subdir.conf
new file mode 100644
index 000000000000..a9dcd7c3888b
--- /dev/null
+++ b/kanboard-nginx-subdir.conf
@@ -0,0 +1,40 @@
+# Example configuration for running kanboard in a subdirectory, called kanbooard, on an existing site
+
+location /kanboard {
+ alias /usr/share/webapps/kanboard;
+
+ access_log /var/log/nginx/kanboard_access.log;
+ error_log /var/log/nginx/kanboard_error.log;
+ index index.php index.html;
+
+ #try_files $uri $uri/ /index.php$is_args$args;
+
+ # Deny access to the directory data
+ location ~ ^/kanboard/data/ {
+ deny all;
+ return 404;
+ }
+
+ # Deny access to .htaccess
+ location ~ /kanboard/\.ht {
+ deny all;
+ return 404;
+ }
+
+ location ~ /kanboard/(config|config.default|kanboard).php$
+ {
+ deny all;
+ return 404;
+ }
+
+ location ~ /kanboard/(.+\.php)$ {
+ include fastcgi_params;
+ try_files $uri =404;
+ fastcgi_pass unix:/var/run/php-fpm/php-fpm.sock;
+ fastcgi_split_path_info ^(.+\.php)(/.+)$;
+ fastcgi_param SCRIPT_FILENAME /usr/share/webapps/$fastcgi_script_name;
+ fastcgi_index index.php;
+ }
+}
+
+
diff --git a/kanboard-nginx.conf b/kanboard-nginx.conf
new file mode 100644
index 000000000000..c9e456362a9e
--- /dev/null
+++ b/kanboard-nginx.conf
@@ -0,0 +1,35 @@
+# Example configuration for a dedicated kanboard site
+server {
+
+listen 80;
+server_name kanboard.domain.tld;
+root /usr/share/webapps/kanboard;
+index index.php index.html;
+
+location / {
+ try_files $uri $uri/ /index.php$is_args$args;
+
+# If Kanboard is under a subfolder
+# try_files $uri $uri/ /kanboard/index.php;
+}
+
+location ~ \.php$ {
+ try_files $uri =404;
+ fastcgi_split_path_info ^(.+\.php)(/.+)$;
+ fastcgi_pass unix:/var/run/php5-fpm.sock;
+ fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
+ fastcgi_index index.php;
+ include fastcgi_params;
+}
+
+# Deny access to the directory data
+location ~* /data {
+ deny all;
+ return 404;
+}
+
+# Deny access to .htaccess
+location ~ /\.ht {
+ deny all;
+ return 404;
+}
diff --git a/kanboard.install b/kanboard.install
index 33d6fb2c0e6a..bb96a0012a91 100644
--- a/kanboard.install
+++ b/kanboard.install
@@ -1,7 +1,7 @@
pre_upgrade() {
echo "Close all sessions on your current kanboard instance"
echo "Kanboard database upgrades are automatic"
- read -p "BACKUP YOUR KANBOARD DATABASE AND DATA DIRECTORY BEFORE UPGRADING!!!"
+ echo "BACKUP YOUR KANBOARD DATABASE AND DATA DIRECTORY BEFORE UPGRADING!!!"
}
post_install() {
echo 'To get started you need to: