summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-29 13:25:02 +0800
committerzxp198210052024-01-29 13:25:02 +0800
commit5984bc207d7539cfb964bfd3fda9c37e4262803d (patch)
tree87adf439c60cdc7877df6b50866b0442994c86a0
parent662542899377d77c1b1c28253e97ad0dabb6990c (diff)
downloadaur-5984bc207d7539cfb964bfd3fda9c37e4262803d.tar.gz
update to 0.5.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
-rw-r--r--kando.sh7
3 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53bafd05ddc9..b73098fd1072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = kando-bin
pkgdesc = A pie menu for the desktop. It will be highly customizable and will allow you to create your own menus and actions.
- pkgver = 0.4.1
+ pkgver = 0.5.0
pkgrel = 1
url = https://ko-fi.com/post/Introducing-Ken-Do-L3L7L0FQ2
arch = x86_64
license = MIT
depends = electron28
- depends = libxtst
- provides = kando=0.4.1
+ provides = kando=0.5.0
conflicts = kando
- source = kando-0.4.1.deb::https://github.com/kando-menu/kando/releases/download/v0.4.1/kando_0.4.1_amd64.deb
- source = LICENSE-0.4.1::https://raw.githubusercontent.com/kando-menu/kando/v0.4.1/LICENSE.md
+ source = kando-0.5.0.rpm::https://github.com/kando-menu/kando/releases/download/v0.5.0/kando-0.5.0-1.x86_64.rpm
+ source = LICENSE-0.5.0::https://raw.githubusercontent.com/kando-menu/kando/v0.5.0/LICENSE.md
source = kando.sh
- sha256sums = 71f199cb2f765c041091e92304e2358f17ba5675ccb347d37620facb1a59603c
+ sha256sums = 780c73cbd2dd350e76df5a045314901b0305feff4a20c80060c2e4424e52591a
sha256sums = fd6cb731b549de5452efacb0833cda7a328eb5263537d29ca18de9d7938f7bab
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = kando-bin
diff --git a/PKGBUILD b/PKGBUILD
index da4894984e76..f79a5c71e5bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=kando-bin
-pkgver=0.4.1
+pkgver=0.5.0
_electronversion=28
pkgrel=1
pkgdesc="A pie menu for the desktop. It will be highly customizable and will allow you to create your own menus and actions. "
@@ -12,22 +12,20 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'libxtst'
)
source=(
- "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
+ "${pkgname%-bin}-${pkgver}.rpm::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-1.${CARCH}.rpm"
"LICENSE-${pkgver}::https://raw.githubusercontent.com/kando-menu/kando/v${pkgver}/LICENSE.md"
"${pkgname%-bin}.sh"
)
-sha256sums=('71f199cb2f765c041091e92304e2358f17ba5675ccb347d37620facb1a59603c'
+sha256sums=('780c73cbd2dd350e76df5a045314901b0305feff4a20c80060c2e4424e52591a'
'fd6cb731b549de5452efacb0833cda7a328eb5263537d29ca18de9d7938f7bab'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@appasar@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/kando.sh b/kando.sh
index aacd8f895847..0d20cddc70ca 100644
--- a/kando.sh
+++ b/kando.sh
@@ -8,8 +8,7 @@ export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file