summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-01 15:37:36 +0800
committerzxp198210052023-08-01 15:37:36 +0800
commite3ad32048194bb17276f9326c46e643b2cc08422 (patch)
tree79f76bfe18c3cb2e6a85c9e41c84fc864b4bad3d
downloadaur-e3ad32048194bb17276f9326c46e643b2cc08422.tar.gz
first release
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD21
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d99c7d80445
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = kangaroo-max-bin
+ pkgdesc = A SQL client and admin tool for popular databases(SQLite/MySQL/PostgreSQL/...),support table design,query,model,sync,export/import etc,focus on comfortable,fun and developer friendly.
+ pkgver = 3.91.1
+ pkgrel = 1
+ url = https://www.datatable.online
+ arch = x86_64
+ license = custom
+ depends = cairo
+ depends = libadwaita
+ depends = gtksourceview5
+ depends = libgee
+ depends = qrencode
+ depends = libsoup3
+ depends = gtk4
+ depends = libxml2
+ depends = uchardet
+ depends = json-glib
+ depends = glibc
+ depends = hiredis
+ depends = gdk-pixbuf2
+ depends = hicolor-icon-theme
+ depends = openssl
+ depends = libarchive
+ depends = glib2
+ depends = pango
+ depends = libpanel
+ depends = sqlcipher
+ depends = mariadb-libs
+ depends = postgresql-libs
+ depends = unixodbc
+ provides = kangaroo-3.91.1
+ conflicts = kangaroo-max
+ conflicts = kangaroo
+ source = kangaroo-max-3.91.1.pkg.tar.zst::https://github.com/dbkangaroo/kangaroo/releases/download/v3.91.1.230801/kangaroo-max-3.90.2.230801-1-x86_64.pkg.tar.zst
+ source = LICENSE::https://www.datatable.online/en/license/service-agreement.html#_8-liability-limitation
+ sha256sums = 7c526127e14dbeafa69a818cef61710dd8441b677e83f5b5480dbf90e673146a
+ sha256sums = de8f70006ea38432c7187b538698093a447d1b349f945c0e9ffcf2afa4b86e04
+
+pkgname = kangaroo-max-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..245c24df9b52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=kangaroo-max-bin
+pkgver=3.91.1
+pkgrel=1
+pkgdesc="A SQL client and admin tool for popular databases(SQLite/MySQL/PostgreSQL/...),support table design,query,model,sync,export/import etc,focus on comfortable,fun and developer friendly."
+arch=('x86_64')
+url="https://www.datatable.online"
+_githuburl="https://github.com/dbkangaroo/kangaroo"
+license=("custom")
+provides=("${pkgname%-max-bin}-${pkgver}")
+conflicts=("${pkgname%-bin}" "${pkgname%-max-bin}")
+depends=('cairo' 'libadwaita' 'gtksourceview5' 'libgee' 'qrencode' 'libsoup3' 'gtk4' 'libxml2' 'uchardet' 'json-glib' 'glibc' 'hiredis' \
+ 'gdk-pixbuf2' 'hicolor-icon-theme' 'openssl' 'libarchive' 'glib2' 'pango' 'libpanel' 'sqlcipher' 'mariadb-libs' 'postgresql-libs' 'unixodbc')
+source=("${pkgname%-bin}-${pkgver}.pkg.tar.zst::${_githuburl}/releases/download/v${pkgver}.230801/${pkgname%-bin}-3.90.2.230801-1-${CARCH}.pkg.tar.zst"
+ "LICENSE::${url}/en/license/service-agreement.html#_8-liability-limitation")
+sha256sums=('7c526127e14dbeafa69a818cef61710dd8441b677e83f5b5480dbf90e673146a'
+ 'de8f70006ea38432c7187b538698093a447d1b349f945c0e9ffcf2afa4b86e04')
+package() {
+ cp -p -a "${srcdir}/usr" "${pkgdir}"
+ install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file