summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2021-02-20 21:03:41 +0100
committerml2021-02-20 21:03:41 +0100
commitde124a20aaa15084be36fc8b83f7e57380577968 (patch)
tree5f030787d5e85152f84b9612ac9a2090bd7cca24
parent0448d22f99b89aadb9bafd8f67a6eafdde337cff (diff)
downloadaur-de124a20aaa15084be36fc8b83f7e57380577968.tar.gz
updpkg: kaniko 1.3.0-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 4 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fac7aab30380..17d03f025a70 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kaniko
pkgdesc = Build Container Images In Kubernetes
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/GoogleContainerTools/kaniko
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index 37918d23033b..9e86a84393da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Matthias Lisin <ml@visu.li>
+# Maintainer: ml <>
# Contributor: Fredy GarcĂ­a <frealgagu at gmail dot com>
pkgname=kaniko
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc='Build Container Images In Kubernetes'
arch=('x86_64')
url="https://github.com/GoogleContainerTools/kaniko"
@@ -13,11 +13,6 @@ makedepends=('go')
source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
sha256sums=('cf2d915aeb5e82ab2f4b241d1b8b251938df57f7b89c610bf51a1a4eda40ca3c')
-prepare() {
- cd "$pkgname-$pkgver"
- go mod download
-}
-
build() {
cd "$pkgname-$pkgver"
export CGO_ENABLED=1
@@ -25,8 +20,7 @@ build() {
export CGO_CPPFLAGS="$CPPFLAGS"
export CGO_CXXFLAGS="$CXXFLAGS"
export CGO_LDFLAGS="$LDFLAGS"
- # -mod=readonly not working currently
- export GOFLAGS='-buildmode=pie -modcacherw'
+ export GOFLAGS='-buildmode=pie -mod=vendor -modcacherw'
go build -trimpath -o . -ldflags="-linkmode=external -X=github.com/GoogleContainerTools/kaniko/pkg/version.version=v$pkgver" ./cmd/...
}