summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDX372020-01-04 14:23:17 +0700
committerDX372020-01-04 14:23:43 +0700
commit0ce19aa57f92cbe40cffa35f61c738f0d789e875 (patch)
tree80ebc5fe0e9ab8533fdcdf0293620ae2ada8a7a3
parentd685d627c71887953fb30346702455cc9ddb6065 (diff)
downloadaur-0ce19aa57f92cbe40cffa35f61c738f0d789e875.tar.gz
return db backends; fixes
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01906f2b117e..028b1b40af08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,22 @@
pkgbase = kannel
pkgdesc = Kannel is a compact and very powerful open source WAP and SMS gateway, it comes with extras!
pkgver = 1.4.5
- pkgrel = 1
+ pkgrel = 2
url = https://kannel.org/
install = kannel.install
arch = any
groups = base-devel
license = custom
+ makedepends = mariadb
+ makedepends = postgresql
+ makedepends = sqlite
+ makedepends = hiredis
depends = bison
depends = libxml2
optdepends = mariadb: MySQL database backend
+ optdepends = postgresql: database backend
optdepends = sqlite: SQLite3 database backend
+ optdepends = hiredis
source = https://kannel.org/download/1.4.5/gateway-1.4.5.tar.gz
source = kannel.conf
source = modems.conf
diff --git a/PKGBUILD b/PKGBUILD
index 8c60bd57b021..617635ddbff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,18 @@
pkgname=kannel
pkgver=1.4.5
-pkgrel=1
+pkgrel=2
pkgdesc="Kannel is a compact and very powerful open source WAP and SMS gateway, it comes with extras!"
arch=('any')
license=('custom')
url="https://kannel.org/"
install=kannel.install
depends=('bison' 'libxml2')
-# conflicts=('bison')
+makedepends=('mariadb' 'postgresql' 'sqlite' 'hiredis')
optdepends=('mariadb: MySQL database backend'
- 'sqlite: SQLite3 database backend')
+ 'postgresql: database backend'
+ 'sqlite: SQLite3 database backend'
+ 'hiredis')
groups=('base-devel')
source=("https://kannel.org/download/${pkgver}/gateway-${pkgver}.tar.gz"
kannel.conf
@@ -41,7 +43,9 @@ prepare()
build() {
cd ${srcdir}/gateway-${pkgver}
- ./configure --prefix=/usr/bin --mandir=/usr/share/man --enable-start-stop-daemon
+ ./configure --prefix=/usr --mandir=/usr/share/man --enable-start-stop-daemon --with-mysql --with-sqlite3 --with-pgsql --with-redis
+ make libgw.a
+ make libgwlib.a
make
}
@@ -64,7 +68,7 @@ package() {
install -Dm644 kannel.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/kannel.conf"
cd gateway-${pkgver}
- make DESTDIR=${pkgdir} install install-test install-checks install-contrib install-docs
+ make DESTDIR=${pkgdir} install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}