summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPi-Yueh Chuang2020-06-11 16:45:13 -0400
committerPi-Yueh Chuang2020-06-11 16:45:13 -0400
commit87bbf5df59df1d69386b1a1d0cd034b5bcdfc6a1 (patch)
tree43dfc130c449ffcf465268f9e6b7fcc488d81a56
parentb0274f17d52ff5f329ae56e2264b843679e13041 (diff)
downloadaur-87bbf5df59df1d69386b1a1d0cd034b5bcdfc6a1.tar.gz
upgpkg: kanshi-git r85.846b725-1
- bump version number - move wlroots to makedepends - add wayland to depends - align the pkgdesc with Arch's official kanshi package - use compilation/linking flags in /etc/makepkg.conf - install LICENSE and README.md to align with the official package
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD42
2 files changed, 30 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dde12c9c8305..0fc07288b828 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kanshi-git
- pkgdesc = Dynamic display configuration for WMs like i3/sway
- pkgver = r73.823cdb0
- pkgrel = 2
+ pkgdesc = Dynamic output configuration for Wayland WMs
+ pkgver = r85.846b725
+ pkgrel = 1
url = https://github.com/emersion/kanshi
arch = x86_64
license = MIT
@@ -9,8 +9,8 @@ pkgbase = kanshi-git
makedepends = meson
makedepends = ninja
makedepends = scdoc
- makedepends = wayland
- depends = wlroots>=0.7
+ makedepends = wlroots>=0.7
+ depends = wayland
provides = kanshi
conflicts = kanshi
source = kanshi::git+https://github.com/emersion/kanshi.git
diff --git a/PKGBUILD b/PKGBUILD
index c4f791c485db..024a9faa9430 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Maintainer: Ben Widawsky <ben@bwidawsk.net>
+# Maintainer: Pi-Yueh Chuang <pychuang@pm.me>
+# Contributor: Ben Widawsky <ben@bwidawsk.net>
pkgname=kanshi-git
-pkgver=r73.823cdb0
-pkgrel=2
-pkgdesc="Dynamic display configuration for WMs like i3/sway"
+pkgver=r85.846b725
+pkgrel=1
+pkgdesc="Dynamic output configuration for Wayland WMs"
arch=(x86_64)
url="https://github.com/emersion/kanshi"
license=('MIT')
groups=()
-depends=('wlroots>=0.7')
-makedepends=('git' 'meson' 'ninja' 'scdoc' 'wayland')
+depends=('wayland')
+makedepends=('git' 'meson' 'ninja' 'scdoc' 'wlroots>=0.7')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
replaces=()
@@ -23,25 +24,32 @@ md5sums=('SKIP')
# a description of each element in the source array.
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}/${pkgname%-git}"
- mkdir -p build
- meson build \
- --buildtype=release \
- --prefix=/usr
+ cd "${srcdir}/${pkgname%-git}"
+ mkdir build
+
+ # meson does not use the variables in /etc/makepkg.conf automatically
+ CPPFLAGS=${CPPFLAGS} CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS} LDFLAGS=${LDFLAGS} \
+ meson build \
+ --buildtype=release \
+ --prefix=/usr
}
build() {
- cd "${srcdir}/${pkgname%-git}"
- ninja -C build
+ cd "${srcdir}/${pkgname%-git}"
+ ninja -C build
}
package() {
- cd "$srcdir/${pkgname%-git}"
- DESTDIR="$pkgdir/" ninja -C build install
+ cd "$srcdir/${pkgname%-git}"
+ DESTDIR="$pkgdir/" ninja -C build install
+ # to shut up namcap's warning, even though it's a MIT license
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
+ # Arch's official Kanshi package installs README, so we do the same
+ install -Dm644 "README.md" -t "$pkgdir/usr/share/doc/$pkgname"
}