summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPi-Yueh Chuang2020-10-11 22:28:20 -0400
committerPi-Yueh Chuang2020-10-11 22:28:20 -0400
commitafb315f660c38afcdc28f47a29aae5de8e0afa82 (patch)
treec9b2d25c2e5caceb88e54fc1f24ca84bcac2de63
parent87bbf5df59df1d69386b1a1d0cd034b5bcdfc6a1 (diff)
downloadaur-afb315f660c38afcdc28f47a29aae5de8e0afa82.tar.gz
upgpkg: kanshi-git r89.7095bed-1
- bump the version number - update meson build workflow based on https://wiki.archlinux.org/index.php/Meson_package_guidelines
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD31
2 files changed, 10 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fc07288b828..aca0eef7c08d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kanshi-git
pkgdesc = Dynamic output configuration for Wayland WMs
- pkgver = r85.846b725
+ pkgver = r89.7095bed
pkgrel = 1
url = https://github.com/emersion/kanshi
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 024a9faa9430..71ab508267da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pi-Yueh Chuang <pychuang@pm.me>
# Contributor: Ben Widawsky <ben@bwidawsk.net>
pkgname=kanshi-git
-pkgver=r85.846b725
+pkgver=r89.7095bed
pkgrel=1
pkgdesc="Dynamic output configuration for Wayland WMs"
arch=(x86_64)
@@ -20,36 +20,23 @@ source=('kanshi::git+https://github.com/emersion/kanshi.git')
noextract=()
md5sums=('SKIP')
-# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
-# a description of each element in the source array.
-
pkgver() {
cd "$srcdir/${pkgname%-git}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${pkgname%-git}"
- mkdir build
-
- # meson does not use the variables in /etc/makepkg.conf automatically
- CPPFLAGS=${CPPFLAGS} CFLAGS=${CFLAGS} CXXFLAGS=${CXXFLAGS} LDFLAGS=${LDFLAGS} \
- meson build \
- --buildtype=release \
- --prefix=/usr
-}
-
build() {
- cd "${srcdir}/${pkgname%-git}"
- ninja -C build
+ # arch-meson automatically sets prefix and other options
+ arch-meson --buildtype=release "${srcdir}/build" "${srcdir}/${pkgname%-git}"
+ # compile
+ meson compile -C "${srcdir}/build" -j 0 --verbose
}
package() {
- cd "$srcdir/${pkgname%-git}"
- DESTDIR="$pkgdir/" ninja -C build install
-
+ # install to $pkgdir
+ DESTDIR="$pkgdir/" meson install -C "${srcdir}/build"
# to shut up namcap's warning, even though it's a MIT license
- install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 "$srcdir/${pkgname%-git}/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname"
# Arch's official Kanshi package installs README, so we do the same
- install -Dm644 "README.md" -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 "$srcdir/${pkgname%-git}/README.md" -t "$pkgdir/usr/share/doc/$pkgname"
}