summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gott2023-01-10 13:38:27 -0500
committerGraeme Gott2023-01-10 13:38:27 -0500
commit05626e2909b09eb5e5ed7ff7b2341c5186cec36f (patch)
tree143fb395a7e36932f30493a3c73c7db968e8ca23
parent1ee3b2964bdfddd74190d5ccfefde7ed3fe3aea9 (diff)
downloadaur-05626e2909b09eb5e5ed7ff7b2341c5186cec36f.tar.gz
Update to 1.6.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73ce49a4ab54..1bec94681846 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kapow
pkgdesc = Punch clock to track time spent on projects
- pkgver = 1.6.0
+ pkgver = 1.6.1
pkgrel = 1
url = https://gottcode.org/kapow/
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = kapow
makedepends = cmake
makedepends = qt6-tools
depends = qt6-base
- source = https://gottcode.org/kapow/kapow-1.6.0-src.tar.bz2
- sha256sums = d97c088d772a0d7af1b1ae2228ab656c2e4cb02684ba1966d0a600563ac73e0c
+ source = https://gottcode.org/kapow/kapow-1.6.1.tar.bz2
+ sha256sums = 02d28c49dc84c53be1d42042f9e5e063369e098819d5cac89ce07fc3a8dd4a9d
pkgname = kapow
diff --git a/PKGBUILD b/PKGBUILD
index 8d9fa9e39420..cb407fe58099 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Graeme Gott <graeme@gottcode.org>
pkgname=kapow
-pkgver=1.6.0
+pkgver=1.6.1
pkgrel=1
pkgdesc='Punch clock to track time spent on projects'
arch=('x86_64')
-url="https://gottcode.org/$pkgname/"
+url="https://gottcode.org/${pkgname}/"
license=('GPL3')
depends=('qt6-base')
makedepends=('cmake' 'qt6-tools')
-source=("https://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
-sha256sums=('d97c088d772a0d7af1b1ae2228ab656c2e4cb02684ba1966d0a600563ac73e0c')
+source=("https://gottcode.org/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('02d28c49dc84c53be1d42042f9e5e063369e098819d5cac89ce07fc3a8dd4a9d')
build() {
- cmake -B build -S $pkgbase-$pkgver \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -B build -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
cmake --build build
}