summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Francois Chevrette2019-09-06 16:04:14 -0400
committerJean-Francois Chevrette2019-09-06 16:04:14 -0400
commit378b8df2dafcee8e4dd8163338613e302510e750 (patch)
tree6a98ae4446cbe2f3d1862c74a0e2c3141e70c895
parent8e45ec82c3816a5b9a2f343d47c91b0ad5ca5c4d (diff)
downloadaur-378b8df2dafcee8e4dd8163338613e302510e750.tar.gz
strip pwd from go binary
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e13d2ddf9c28..26cba029bc0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kapp-git
pkgdesc = kapp is a simple deployment tool focused on the concept of "Kubernetes application"
pkgver = r193.b0d6b82
- pkgrel = 1
+ pkgrel = 2
url = https://get-kapp.io/
arch = x86_64
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index d345f2ceeb27..90993dc827b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=kapp
pkgname=${_pkgname}-git
pkgver=r193.b0d6b82
-pkgrel=1
+pkgrel=2
pkgdesc='kapp is a simple deployment tool focused on the concept of "Kubernetes application"'
url="https://get-kapp.io/"
license=('Apache')
@@ -28,6 +28,7 @@ build() {
cd "${srcdir}/src/github.com/k14s/${_pkgname}"
export GOPATH="${srcdir}"
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
mkdir -p tmp
build_values_path="../../../${BUILD_VALUES:-./hack/build-values-default.yml}"