summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-07 15:01:41 +0800
committerzxp198210052024-03-07 15:01:41 +0800
commitf28cc7a168a53b7253f2ecd6ac787d0fde1a6290 (patch)
tree0df01472e12cdab1c92039a3e45b3d657c62e994
parent62d638055113eb87f047265b3d41da9d3d2a2e8a (diff)
downloadaur-f28cc7a168a53b7253f2ecd6ac787d0fde1a6290.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
-rw-r--r--karbonized.sh3
3 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 304e77ce6bd2..b25a73787f74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = karbonized-bin
pkgdesc = Awesome Image Generator for Code Snippets & Screenshots
pkgver = 1.12.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/yossTheDev/karbonized
arch = x86_64
license = Apache-2.0
- makedepends = squashfuse
+ makedepends = fuse2
depends = electron25
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk2
provides = karbonized=1.12.0
conflicts = karbonized
source = karbonized-1.12.0.AppImage::https://github.com/yossTheDev/karbonized/releases/download/v1.12.0/karbonized-1.12.0.AppImage
source = karbonized.sh
sha256sums = ec525f543d01b865a12896eed63c1334fb4acc2178cc68af009bc314a8de8a62
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = karbonized-bin
diff --git a/PKGBUILD b/PKGBUILD
index 24c75773c15d..c17c2dbdb126 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=karbonized-bin
pkgver=1.12.0
_electronversion=25
-pkgrel=5
+pkgrel=6
pkgdesc="Awesome Image Generator for Code Snippets & Screenshots"
arch=('x86_64')
url="https://github.com/yossTheDev/karbonized"
@@ -11,19 +11,16 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
)
makedepends=(
- 'squashfuse'
+ 'fuse2'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}.AppImage"
"${pkgname%-bin}.sh"
)
sha256sums=('ec525f543d01b865a12896eed63c1334fb4acc2178cc68af009bc314a8de8a62'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/karbonized.sh b/karbonized.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/karbonized.sh
+++ b/karbonized.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then