summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-06-10 12:03:25 -0600
committergustawho2021-06-10 12:03:25 -0600
commitd1baa2c611f2a835b2ce1356868e8f405b2daf5c (patch)
treed1f75d7ae3393abf0a79c0f4528b605087d53a6b
downloadaur-d1baa2c611f2a835b2ce1356868e8f405b2daf5c.tar.gz
Plasma Mobile Gear 21.06
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD23
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15d492258ca3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = kasts
+ pkgdesc = Kirigami-based podcast player
+ pkgver = 21.06
+ pkgrel = 1
+ url = https://invent.kde.org/plasma-mobile/kasts
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ license = GPL2
+ makedepends = extra-cmake-modules
+ makedepends = qt5-svg
+ makedepends = qt5-tools
+ depends = qt5-multimedia
+ depends = qt5-quickcontrols2
+ depends = purpose
+ depends = kirigami2
+ depends = ki18n
+ depends = kconfig
+ depends = kcoreaddons
+ depends = ki18n
+ depends = syndication
+ source = https://download.kde.org/stable/plasma-mobile/21.06/kasts-21.06.tar.xz
+ sha256sums = 12
+
+pkgname = kasts
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f7a41434529
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
+
+pkgname=kasts
+pkgver=21.06
+pkgrel=1
+arch=('x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+pkgdesc="Kirigami-based podcast player"
+url="https://invent.kde.org/plasma-mobile/kasts"
+license=('GPL2')
+depends=('qt5-multimedia' 'qt5-quickcontrols2' 'purpose' 'kirigami2'
+ 'ki18n' 'kconfig' 'kcoreaddons' 'ki18n' 'syndication')
+makedepends=('extra-cmake-modules' 'qt5-svg' 'qt5-tools')
+source=("https://download.kde.org/stable/plasma-mobile/${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('12')
+
+build() {
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -B build -S "${pkgname}-${pkgver}"
+ cmake --build build --config Release
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install build --config Release
+} \ No newline at end of file