summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2022-07-01 23:08:44 -0600
committergustawho2022-07-01 23:08:44 -0600
commit3e455e8e1bb392c2b021e61e7157b6bff99e0e32 (patch)
treee6f138065e9d16207248fed690d17c6ab5fcf65a
parentcbddf44ebcd84b7a76a2b7e51e33ad7cea95289d (diff)
downloadaur-3e455e8e1bb392c2b021e61e7157b6bff99e0e32.tar.gz
PKGBUILD format
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdbd60b4d504..419c68f913c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kasts-git
pkgdesc = Kirigami-based podcast player
- pkgver = r542.eab5d08
+ pkgver = 22.06.r12.gfbe745d
pkgrel = 1
url = https://invent.kde.org/plasma-mobile/kasts
arch = x86_64
@@ -24,6 +24,7 @@ pkgbase = kasts-git
depends = ki18n
depends = syndication
depends = taglib
+ depends = threadweaver
provides = kasts
conflicts = kasts
source = git+https://invent.kde.org/plasma-mobile/kasts.git
diff --git a/PKGBUILD b/PKGBUILD
index df3506747545..7f3d88ab3b4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=kasts-git
-pkgver=r542.eab5d08
+pkgver=22.06.r12.gfbe745d
pkgrel=1
arch=('x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
pkgdesc="Kirigami-based podcast player"
url="https://invent.kde.org/plasma-mobile/kasts"
license=('GPL2')
depends=('qt5-multimedia' 'qt5-quickcontrols2' 'qtkeychain-qt5' 'purpose' 'kirigami2'
- 'ki18n' 'kconfig' 'kcoreaddons' 'ki18n' 'syndication' 'taglib')
+ 'ki18n' 'kconfig' 'kcoreaddons' 'ki18n' 'syndication' 'taglib' 'threadweaver')
makedepends=('extra-cmake-modules' 'git' 'qt5-svg' 'qt5-tools')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
@@ -18,8 +18,8 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --first-parent --match 'v[0-9][0-9.][0-9.]*' | \
+ sed 's=^v==;s=^\([0-9][0-9.]*\)-\([a-zA-Z]\+\)=\1\2=;s=\([0-9]\+-g\)=r\1=;s=-=.=g'
)
}
@@ -30,4 +30,4 @@ build() {
package() {
DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
-} \ No newline at end of file
+}