summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorImNtReal2016-07-06 15:33:51 -0400
committerImNtReal2016-07-06 15:33:51 -0400
commitb0ce521b6271933d2b8e7b66a3d63d9ea0060ee1 (patch)
tree2a6713236ae6270efa575a0d0a8badc4bf0da0b0
downloadaur-b0ce521b6271933d2b8e7b66a3d63d9ea0060ee1.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..950509245480
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Jul 6 19:33:43 UTC 2016
+pkgbase = kasync-git
+ pkgdesc = A C++ library for controlling asynchronous tasks
+ pkgver = r88.6bc6092
+ pkgrel = 1
+ url = https://github.com/KDE/kasync
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ depends = qt5-base
+ provides = kasync
+ conflicts = kasync
+ source = git://anongit.kde.org/kasync.git
+ sha256sums = SKIP
+
+pkgname = kasync-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d07936b9377
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=kasync-git
+pkgver=r88.6bc6092
+pkgrel=1
+pkgdesc='A C++ library for controlling asynchronous tasks'
+arch=('i686' 'x86_64')
+url='https://github.com/KDE/kasync'
+license=('GPL')
+depends=('qt5-base')
+makedepends=('extra-cmake-modules' 'git')
+conflicts=(kasync)
+provides=(kasync)
+source=("git://anongit.kde.org/kasync.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd kasync
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kasync \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}