summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorflovo2020-03-30 11:59:04 +0200
committerflovo2020-03-30 11:59:04 +0200
commit844db58e33b510fd4935269e45b985d315991d45 (patch)
tree61c2ffd7ffedf7702892a92a2174b392ef322a86
parent6c87effc0d4a7b8ff071bef5ba63d9edae9f3b04 (diff)
downloadaur-844db58e33b510fd4935269e45b985d315991d45.tar.gz
v1.3.4 updating engine and nets
https://github.com/lightvector/KataGo/releases/tag/v1.3.4
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
3 files changed, 22 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3866b016466..318d687b2f8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = katago-opencl
pkgdesc = Baduk engine with no human-provided knowledge.
- pkgver = 1.3.3
- pkgrel = 2
+ pkgver = 1.3.4
+ pkgrel = 1
url = https://github.com/lightvector/KataGo
arch = x86_64
license = MIT
@@ -12,14 +12,14 @@ pkgbase = katago-opencl
depends = ocl-icd
depends = boost-libs
provides = katago
- source = katago-opencl::git+https://github.com/lightvector/KataGo#tag=v1.3.3-nets
- source = g170e-b20c256x2-s2971705856-d633407024.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.3-nets/g170e-b20c256x2-s2971705856-d633407024.bin.gz
- source = g170-b30c320x2-s1840604672-d633482024.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.3-nets/g170-b30c320x2-s1840604672-d633482024.bin.gz
- source = g170-b40c256x2-s1929311744-d633132024.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.3-nets/g170-b40c256x2-s1929311744-d633132024.bin.gz
+ source = katago-opencl::git+https://github.com/lightvector/KataGo#tag=v1.3.4
+ source = g170e-b20c256x2-s3354994176-d716845198.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.4/g170e-b20c256x2-s3354994176-d716845198.bin.gz
+ source = g170-b30c320x2-s2271129088-d716970897.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.4/g170-b30c320x2-s2271129088-d716970897.bin.gz
+ source = g170-b40c256x2-s2383550464-d716628997.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.4/g170-b40c256x2-s2383550464-d716628997.bin.gz
sha256sums = SKIP
- sha256sums = dba074142b9da4822ed9ad91c676372fd943c0c115b7975773dd292b9e96a899
- sha256sums = 2f066112e163de396f5bd56b94162419f16ff48e9fb9836c35a711122ecc9a32
- sha256sums = acbdd1aa883d7d8d60101cdcd0c75754ec25dba66b4d60d8d284427cf645124d
+ sha256sums = fa73912ad2fc84940e5b9edc78a3ef2d775ed18f3c9a735f4051c378b7526d6e
+ sha256sums = 16a907dca44709d69c64f738c9cce727c91406d10aea212631db30da66bef98a
+ sha256sums = 08721ba6daef132f12255535352c6b15bcc51c56f48761ddfefcd522ec47a3f2
pkgname = katago-opencl
diff --git a/.gitignore b/.gitignore
index 62ea77e4f5e6..a9d2bae14ad2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ katago-opencl
weights-b20.bin.gz
weights-b30.bin.gz
weights-b40.bin.gz
+g*.bin.gz
diff --git a/PKGBUILD b/PKGBUILD
index 3bacc4dafb4c..e2a07f14375d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: flovo <flovo-git-commit at f-voegele dot de>
pkgname=katago-opencl
-pkgver=1.3.3
-pkgrel=2
+pkgver=1.3.4
+pkgrel=1
pkgdesc="Baduk engine with no human-provided knowledge."
arch=('x86_64')
provides=("katago")
@@ -10,14 +10,14 @@ url="https://github.com/lightvector/KataGo"
license=('MIT')
depends=('libzip' 'ocl-icd' 'boost-libs')
makedepends=('git' 'opencl-headers' 'cmake')
-source=("${pkgname}::git+https://github.com/lightvector/KataGo#tag=v${pkgver}-nets"
- "g170e-b20c256x2-s2971705856-d633407024.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.3-nets/g170e-b20c256x2-s2971705856-d633407024.bin.gz"
- "g170-b30c320x2-s1840604672-d633482024.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.3-nets/g170-b30c320x2-s1840604672-d633482024.bin.gz"
- "g170-b40c256x2-s1929311744-d633132024.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.3-nets/g170-b40c256x2-s1929311744-d633132024.bin.gz")
+source=("${pkgname}::git+https://github.com/lightvector/KataGo#tag=v${pkgver}"
+ "g170e-b20c256x2-s3354994176-d716845198.bin.gz::https://github.com/lightvector/KataGo/releases/download/v${pkgver}/g170e-b20c256x2-s3354994176-d716845198.bin.gz"
+ "g170-b30c320x2-s2271129088-d716970897.bin.gz::https://github.com/lightvector/KataGo/releases/download/v${pkgver}/g170-b30c320x2-s2271129088-d716970897.bin.gz"
+ "g170-b40c256x2-s2383550464-d716628997.bin.gz::https://github.com/lightvector/KataGo/releases/download/v${pkgver}/g170-b40c256x2-s2383550464-d716628997.bin.gz")
sha256sums=('SKIP'
- 'dba074142b9da4822ed9ad91c676372fd943c0c115b7975773dd292b9e96a899'
- '2f066112e163de396f5bd56b94162419f16ff48e9fb9836c35a711122ecc9a32'
- 'acbdd1aa883d7d8d60101cdcd0c75754ec25dba66b4d60d8d284427cf645124d')
+ 'fa73912ad2fc84940e5b9edc78a3ef2d775ed18f3c9a735f4051c378b7526d6e'
+ '16a907dca44709d69c64f738c9cce727c91406d10aea212631db30da66bef98a'
+ '08721ba6daef132f12255535352c6b15bcc51c56f48761ddfefcd522ec47a3f2')
prepare() {
@@ -34,9 +34,9 @@ build() {
package() {
cd $srcdir/$pkgname
install -Dm755 cpp/katago $pkgdir/usr/bin/katago
- install -Dm644 $srcdir/g170e-b20c256x2-s2971705856-d633407024.bin.gz $pkgdir/usr/share/katago/networks/weights-b20.bin.gz
- install -Dm644 $srcdir/g170-b30c320x2-s1840604672-d633482024.bin.gz $pkgdir/usr/share/katago/networks/weights-b30.bin.gz
- install -Dm644 $srcdir/g170-b40c256x2-s1929311744-d633132024.bin.gz $pkgdir/usr/share/katago/networks/weights-b40.bin.gz
+ install -Dm644 $srcdir/g170e-b20c256x2-s3354994176-d716845198.bin.gz $pkgdir/usr/share/katago/networks/weights-b20.bin.gz
+ install -Dm644 $srcdir/g170-b30c320x2-s2271129088-d716970897.bin.gz $pkgdir/usr/share/katago/networks/weights-b30.bin.gz
+ install -Dm644 $srcdir/g170-b40c256x2-s2383550464-d716628997.bin.gz $pkgdir/usr/share/katago/networks/weights-b40.bin.gz
install -Dm644 $srcdir/katago-opencl/LICENSE $pkgdir/usr/share/licenses/katago-opencl/LICENSE
}