summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorflovo2020-05-26 20:35:01 +0200
committerflovo2020-05-26 20:35:01 +0200
commita4d18bca20f6559682de7833f2731be92c8f186e (patch)
tree7f022cafe351dcfb1c5c6cc2310c1144565ee2bf
parentdbc1ffa0aac3fa69ded71d934c803374bfb328c7 (diff)
downloadaur-a4d18bca20f6559682de7833f2731be92c8f186e.tar.gz
Add boost to makedeps - upgrade version to 1.4.2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d92e0112c663..00046059bb7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = katago-opencl
pkgdesc = Baduk engine with no human-provided knowledge.
- pkgver = 1.3.5
+ pkgver = 1.4.2
pkgrel = 3
url = https://github.com/lightvector/KataGo
arch = x86_64
@@ -8,18 +8,19 @@ pkgbase = katago-opencl
makedepends = git
makedepends = opencl-headers
makedepends = cmake
+ makedepends = boost
depends = libzip
depends = ocl-icd
depends = boost-libs
provides = katago
- source = katago-opencl::git+https://github.com/lightvector/KataGo#tag=v1.3.5
- source = g170e-b20c256x2-s3761649408-d809581368.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.5-nets/g170e-b20c256x2-s3761649408-d809581368.bin.gz
- source = g170-b30c320x2-s2846858752-d829865719.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.5-nets/g170-b30c320x2-s2846858752-d829865719.bin.gz
- source = g170-b40c256x2-s2990766336-d830712531.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.5-nets/g170-b40c256x2-s2990766336-d830712531.bin.gz
+ source = katago-opencl::git+https://github.com/lightvector/KataGo#tag=v1.4.2
+ source = g170e-b20c256x2-s4384473088-d968438914.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.4.0/g170-b20c256x2-s4384473088-d968438914.bin.gz
+ source = g170-b30c320x2-s3530176512-d968463914.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.4.0/g170-b30c320x2-s3530176512-d968463914.bin.gz
+ source = g170-b40c256x2-s3708042240-d967973220.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.4.0/g170-b40c256x2-s3708042240-d967973220.bin.gz
sha256sums = SKIP
- sha256sums = 872175c02c50486c990aa5c2f9f0099ceece7bfcf024c3194dc7fa4760dca6c1
- sha256sums = 1229b83725345694e7d08f5cf1f483b7409583dd532a914b0809485a91c3f5e5
- sha256sums = fc3e56e0ef92801b28cc0f363f31b4436f0ac0f55dff752f270d3ef27346b0b7
+ sha256sums = da070fddb45e4d798a63b0be1960d604ad422690d82ac66b1d4ee41e8bf42536
+ sha256sums = 67bd8f67a0ed251d78626ccd23cd4cdbcc880ffc29b641f65cf79ec9d9be83e5
+ sha256sums = 9053c1f0f7834533b34556d3454fe0de8736d5951a2fe5d02c3aebd3fc20240e
pkgname = katago-opencl
diff --git a/PKGBUILD b/PKGBUILD
index 9bf3a7336fa6..c24c9175c4f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: flovo <flovo-git-commit at f-voegele dot de>
pkgname=katago-opencl
-pkgver=1.3.5
+pkgver=1.4.2
pkgrel=3
pkgdesc="Baduk engine with no human-provided knowledge."
arch=('x86_64')
@@ -9,15 +9,15 @@ provides=("katago")
url="https://github.com/lightvector/KataGo"
license=('MIT')
depends=('libzip' 'ocl-icd' 'boost-libs')
-makedepends=('git' 'opencl-headers' 'cmake')
+makedepends=('git' 'opencl-headers' 'cmake' 'boost')
source=("${pkgname}::git+https://github.com/lightvector/KataGo#tag=v${pkgver}"
- "g170e-b20c256x2-s3761649408-d809581368.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.5-nets/g170e-b20c256x2-s3761649408-d809581368.bin.gz"
- "g170-b30c320x2-s2846858752-d829865719.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.5-nets/g170-b30c320x2-s2846858752-d829865719.bin.gz"
- "g170-b40c256x2-s2990766336-d830712531.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.3.5-nets/g170-b40c256x2-s2990766336-d830712531.bin.gz")
+ "g170e-b20c256x2-s4384473088-d968438914.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.4.0/g170-b20c256x2-s4384473088-d968438914.bin.gz"
+ "g170-b30c320x2-s3530176512-d968463914.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.4.0/g170-b30c320x2-s3530176512-d968463914.bin.gz"
+ "g170-b40c256x2-s3708042240-d967973220.bin.gz::https://github.com/lightvector/KataGo/releases/download/v1.4.0/g170-b40c256x2-s3708042240-d967973220.bin.gz")
sha256sums=('SKIP'
- '872175c02c50486c990aa5c2f9f0099ceece7bfcf024c3194dc7fa4760dca6c1'
- '1229b83725345694e7d08f5cf1f483b7409583dd532a914b0809485a91c3f5e5'
- 'fc3e56e0ef92801b28cc0f363f31b4436f0ac0f55dff752f270d3ef27346b0b7')
+ 'da070fddb45e4d798a63b0be1960d604ad422690d82ac66b1d4ee41e8bf42536'
+ '67bd8f67a0ed251d78626ccd23cd4cdbcc880ffc29b641f65cf79ec9d9be83e5'
+ '9053c1f0f7834533b34556d3454fe0de8736d5951a2fe5d02c3aebd3fc20240e')
prepare() {
cd $srcdir/$pkgname
@@ -33,9 +33,9 @@ build() {
package() {
cd $srcdir/$pkgname
install -Dm755 cpp/katago $pkgdir/usr/bin/katago
- install -Dm644 $srcdir/g170e-b20c256x2-s3761649408-d809581368.bin.gz $pkgdir/usr/share/katago/networks/weights-b20.bin.gz
- install -Dm644 $srcdir/g170-b30c320x2-s2846858752-d829865719.bin.gz $pkgdir/usr/share/katago/networks/weights-b30.bin.gz
- install -Dm644 $srcdir/g170-b40c256x2-s2990766336-d830712531.bin.gz $pkgdir/usr/share/katago/networks/weights-b40.bin.gz
+ install -Dm644 $srcdir/g170e-b20c256x2-s4384473088-d968438914.bin.gz $pkgdir/usr/share/katago/networks/weights-b20.bin.gz
+ install -Dm644 $srcdir/g170-b30c320x2-s3530176512-d968463914.bin.gz $pkgdir/usr/share/katago/networks/weights-b30.bin.gz
+ install -Dm644 $srcdir/g170-b40c256x2-s3708042240-d967973220.bin.gz $pkgdir/usr/share/katago/networks/weights-b40.bin.gz
install -Dm644 $srcdir/katago-opencl/LICENSE $pkgdir/usr/share/licenses/katago-opencl/LICENSE
}