summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordr460nf1r32021-03-30 13:38:48 +0200
committerdr460nf1r32021-03-30 13:38:48 +0200
commit87e5e72d5cbea7f3a3717dde9584bf9ab8cea08e (patch)
tree843180322a34b94a82f5efcb8c338a76d0ef7a85
parent0c9da945dcfa3a3e42d1af3cd61ce7922668846c (diff)
downloadaur-87e5e72d5cbea7f3a3717dde9584bf9ab8cea08e.tar.gz
Remove splitting
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD45
2 files changed, 26 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c2fc3fea68b..8a13d3ecd4d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,11 @@
pkgbase = kate-git
- pkgver = 21.07.70_r17987.g664722487
+ pkgdesc = Advanced Text Editor
+ pkgver = 21.07.70_r17988.g3d0d58325
pkgrel = 1
+ url = https://www.kde.org/applications/utilities/kate/
arch = x86_64
+ groups = kde-applications-git
+ groups = kde-utilities-git
license = GPL
license = LGPL
license = FDL
@@ -14,25 +18,6 @@ pkgbase = kate-git
makedepends = kactivities-git
makedepends = kuserfeedback-git
makedepends = git
- provides = kate
- conflicts = kate
- conflicts = kdesdk-kate
- conflicts = kdebase-kwrite
- source = git+https://invent.kde.org/utilities/kate.git
- md5sums = SKIP
-
-pkgname = kwrite-git
- pkgdesc = Text Editor
- url = https://www.kde.org/applications/utilities/kwrite/
- groups = kde-applications-git
- depends = ktexteditor-git
- depends = hicolor-icon-theme
-
-pkgname = kate-git
- pkgdesc = Advanced Text Editor
- url = https://www.kde.org/applications/utilities/kate/
- groups = kde-applications-git
- groups = kde-utilities-git
depends = knewstuff-git
depends = ktexteditor-git
depends = kactivities-git
@@ -43,3 +28,11 @@ pkgname = kate-git
optdepends = python-language-server: Python LSP support
optdepends = texlab: LaTeX LSP support
optdepends = rust: Rust LSP support
+ provides = kate
+ conflicts = kate
+ conflicts = kdesdk-kate
+ conflicts = kdebase-kwrite
+ source = git+https://invent.kde.org/utilities/kate.git
+ md5sums = SKIP
+
+pkgname = kate-git
diff --git a/PKGBUILD b/PKGBUILD
index 55bf73f52ad5..30e3fa2f47f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,18 @@
# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
-pkgbase=kate-git
-pkgname=(kwrite-git kate-git)
-pkgver=21.07.70_r17987.g664722487
+pkgname=kate-git
+pkgver=21.07.70_r17988.g3d0d58325
pkgrel=1
+pkgdesc="Advanced Text Editor"
+groups=(kde-applications-git kde-utilities-git)
+url="https://www.kde.org/applications/utilities/kate/"
+depends=(knewstuff-git ktexteditor-git kactivities-git kuserfeedback-git hicolor-icon-theme)
+optdepends=('konsole-git: open a terminal in Kate'
+ 'clang: C and C++ LSP support'
+ 'python-language-server: Python LSP support'
+ 'texlab: LaTeX LSP support'
+ 'rust: Rust LSP support')
arch=(x86_64)
license=(GPL LGPL FDL)
makedepends=(extra-cmake-modules-git kdoctools-git plasma-framework-git knewstuff-git kitemmodels-git ktexteditor-git kactivities-git kuserfeedback-git git)
@@ -34,34 +42,7 @@ build() {
cmake --build build
}
-package_kwrite-git() {
- pkgdesc="Text Editor"
- groups=(kde-applications-git)
- url="https://www.kde.org/applications/utilities/kwrite/"
- depends=(ktexteditor-git hicolor-icon-theme)
-
- DESTDIR="$pkgdir" cmake --install build
-
- find "$pkgdir" -type f -name '*kate*' -exec rm {} \;
- rm -r "$pkgdir"/usr/lib/qt/plugins/ktexteditor \
- "$pkgdir"/usr/share/doc/HTML/*/{kate,katepart} \
- "$pkgdir"/usr/share/katexmltools \
- "$pkgdir"/usr/share/locale/*/LC_MESSAGES/{ktexteditorpreviewplugin,lspclient,tabswitcherplugin}.mo \
- "$pkgdir"/usr/share/plasma/plasmoids
-}
-
-package_kate-git() {
- pkgdesc="Advanced Text Editor"
- groups=(kde-applications-git kde-utilities-git)
- url="https://www.kde.org/applications/utilities/kate/"
- depends=(knewstuff-git ktexteditor-git kactivities-git kuserfeedback-git hicolor-icon-theme)
- optdepends=('konsole-git: open a terminal in Kate'
- 'clang: C and C++ LSP support'
- 'python-language-server: Python LSP support'
- 'texlab: LaTeX LSP support'
- 'rust: Rust LSP support')
+package() {
+ cd build
DESTDIR="$pkgdir" cmake --install build
-
- find "$pkgdir" -type f -name '*kwrite*' -exec rm {} \;
- rm -r "$pkgdir"/usr/share/doc/HTML/*/kwrite
}