summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorloh.tar2024-03-20 09:11:18 +0100
committerloh.tar2024-03-20 09:32:41 +0100
commit1c831879aa2f5c1a1f06969dce9e7ee3c18a3598 (patch)
tree646d6f8cc84c8f5e2700d5ee374223dff1a899eb
parenta715fbcb85589cf0611ec8f413b591575ec602ae (diff)
downloadaur-1c831879aa2f5c1a1f06969dce9e7ee3c18a3598.tar.gz
Update to 0.9.2
These CMake warning needs to be ignored CMake Warning: Manually-specified variables were not used by the project: KDE_INSTALL_USE_QT_SYS_PATHS See README of the project and send a patch to fix the build system
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d395640a83b7..f3092db1ff60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = kate-indexview-plugin
- pkgdesc = A fork from Kate's SymbolViewer plugin with a couple of improvements
- pkgver = 0.9.1
+ pkgdesc = A fork from Kate's SymbolViewer plugin with a couple of modifications
+ pkgver = 0.9.2
pkgrel = 1
url = https://github.com/loh-tar/KatePlugin-IndexView
arch = i686
arch = x86_64
- license = LGPL
+ license = LGPL-2.0-or-later
makedepends = cmake
makedepends = extra-cmake-modules
- depends = kate
- source = kate-indexview-plugin-0.9.1.tar.gz::https://github.com/loh-tar/KatePlugin-IndexView/archive/v0.9.1.tar.gz
- md5sums = 80dc4fc4638d769add8c17ca52914255
+ depends = kate>=24.02.0
+ source = kate-indexview-plugin-0.9.2.tar.gz::https://github.com/loh-tar/KatePlugin-IndexView/archive/v0.9.2.tar.gz
+ md5sums = d323095ef93d087602ac58581d245a9e
pkgname = kate-indexview-plugin
diff --git a/PKGBUILD b/PKGBUILD
index 500fe1480b76..7d3cd1072edc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Thanks to kate-latex-plugin.git which was my starting point for this PKGBUILD
pkgname="kate-indexview-plugin"
_pkgname="KatePlugin-IndexView"
-pkgver="0.9.1"
+pkgver="0.9.2"
pkgrel="1"
-pkgdesc="A fork from Kate's SymbolViewer plugin with a couple of improvements"
+pkgdesc="A fork from Kate's SymbolViewer plugin with a couple of modifications"
arch=("i686" "x86_64")
url="https://github.com/loh-tar/$_pkgname"
-license=("LGPL")
-depends=("kate")
+license=("LGPL-2.0-or-later")
+depends=("kate>=24.02.0")
makedepends=("cmake" "extra-cmake-modules")
source=("$pkgname-$pkgver.tar.gz::https://github.com/loh-tar/$_pkgname/archive/v$pkgver.tar.gz")
-md5sums=('80dc4fc4638d769add8c17ca52914255')
+md5sums=('d323095ef93d087602ac58581d245a9e')
build()
{
@@ -30,5 +30,6 @@ build()
package()
{
cd "$srcdir/build"
- make DESTDIR="$pkgdir" install
+ # make DESTDIR="$pkgdir" install
+ install -Dm755 index-view/kateindexviewplugin.so "$pkgdir/usr/lib/qt6/plugins/kf6/ktexteditor/index-view/kateindexviewplugin.so"
}