summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarcan1s2015-06-08 19:56:07 +0300
committerarcan1s2015-06-08 19:56:07 +0300
commitf3f1bd3378d8d2b86ca73a83624995c453d976fb (patch)
tree2f40b1c936c8e298b84cfc1cb1c7a720fb56f720
downloadaur-kate-latex-plugin.tar.gz
upload kate-latex-plugin
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f88c110beab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kate-latex-plugin
+ pkgdesc = Kate LaTeX typesetting plugin
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://www.kde-apps.org/content/show.php/Kate+LaTeX+typesetting+plugin?content=84772
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = automoc4
+ depends = kdesdk-kate
+ depends = libxtst
+ source = http://kde-apps.org/CONTENT/content-files/84772-katelatexplugin-0.5.tar.bz2
+ md5sums = d6e30aa41da5279300f5d638ff595a77
+
+pkgname = kate-latex-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8738cac8dad2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bernardo Barros <bernardobarros@gmail.com>
+# Maintainer: Evgeniy "arcanis" Alexeev <esalexeev@gmail.com>
+
+pkgname=kate-latex-plugin
+_pkgname=katelatexplugin
+pkgver=0.5
+pkgrel=1
+pkgdesc="Kate LaTeX typesetting plugin"
+arch=('i686' 'x86_64')
+url="http://www.kde-apps.org/content/show.php/Kate+LaTeX+typesetting+plugin?content=84772"
+license=('GPL')
+depends=('kdesdk-kate' 'libxtst')
+makedepends=('automoc4')
+source=(http://kde-apps.org/CONTENT/content-files/84772-${_pkgname}-${pkgver}.tar.bz2)
+md5sums=('d6e30aa41da5279300f5d638ff595a77')
+
+build()
+{
+ if [[ -d ${srcdir}/build ]]; then
+ rm -rf "${srcdir}/build"
+ fi
+ mkdir "${srcdir}/build"; cd "${srcdir}/build"
+
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` \
+ ../${_pkgname}-${pkgver}
+ make
+}
+
+package()
+{
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+}