summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:32:28 +0200
committerDaniel Nagy2015-06-08 20:32:28 +0200
commite7d312405cc0d9f2f37a02c5368b023683b678c5 (patch)
tree15728539f7701db2fb1fd54c7c08f31b1e1eec1b
downloadaur-e7d312405cc0d9f2f37a02c5368b023683b678c5.tar.gz
import to aur4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD45
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afc4b0ff579f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = kate-syntax-mustache-git
+ pkgdesc = Mustache syntax highlighting for the KDE Katepart.
+ pkgver = 20130127
+ pkgrel = 1
+ url = https://github.com/20after4/Mustache-Highlighting
+ arch = any
+ license = GPL
+ license = BSD
+ makedepends = git
+
+pkgname = kate-syntax-mustache-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b702c671909
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=kate-syntax-mustache-git
+pkgver=20130127
+pkgrel=1
+pkgdesc="Mustache syntax highlighting for the KDE Katepart."
+arch=('any')
+url="https://github.com/20after4/Mustache-Highlighting"
+license=('GPL' 'BSD')
+groups=()
+depends=()
+makedepends=('git')
+noextract=()
+#md5sums=() #generate with 'makepkg -g'
+
+_gitroot=git://github.com/20after4/Mustache-Highlighting.git
+_gitname=kate-mustache
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ mkdir -p $pkgdir/usr/share/apps/katepart/syntax/
+ cp mustache.xml $pkgdir/usr/share/apps/katepart/syntax/
+}
+
+# vim:set ts=2 sw=2 et: