summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitry2019-10-31 21:33:02 +0400
committerDmitry2019-10-31 21:33:02 +0400
commit2306812e254635f24eced2f57ac0ba87697dccba (patch)
tree38f8eccb2d677b27669e35fa77f8282b69f40d27
downloadaur-2306812e254635f24eced2f57ac0ba87697dccba.tar.gz
Initial
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD21
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa82390f15bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = katfetch
+ pkgdesc = A minimal and customizable fetch script.
+ pkgver = 1.2.9
+ pkgrel = 1
+ url = https://gitlab.com/KatHamer/katfetch
+ arch = any
+ license = MIT
+ depends = python-click
+ depends = python-psutil
+ depends = python-hurry-filesize
+ source = katfetch-1.2.9.tar.gz::https://gitlab.com/KatHamer/katfetch/-/archive/1e079b39520664f27c85c289eb5e56b40dbd229b/katfetch-1e079b39520664f27c85c289eb5e56b40dbd229b.tar.gz
+ sha256sums = 94ef602e0d5d5f8e2e9453d9205f51fcdbd916f8042ac80c0acd3778aaaf0666
+
+pkgname = katfetch
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..da9ad853a514
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+katfetch-*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d647a48713e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Auteiy <dmitry@auteiy.me>
+
+pkgname=katfetch
+pkgver=1.2.9
+pkgrel=1
+pkgdesc="A minimal and customizable fetch script."
+arch=(any)
+url="https://gitlab.com/KatHamer/katfetch"
+license=(MIT)
+depends=(python-click python-psutil python-hurry-filesize)
+
+_commit="1e079b39520664f27c85c289eb5e56b40dbd229b"
+source=("$pkgname-$pkgver.tar.gz::https://gitlab.com/KatHamer/katfetch/-/archive/$_commit/katfetch-$_commit.tar.gz")
+
+sha256sums=('94ef602e0d5d5f8e2e9453d9205f51fcdbd916f8042ac80c0acd3778aaaf0666')
+
+package() {
+cd katfetch-$_commit
+python3 setup.py install --root="$pkgdir/"
+install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}