summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralgebro2022-12-07 11:24:17 -0500
committeralgebro2022-12-07 11:24:17 -0500
commit71ee045f9e36e0f3c411e5750af9b9c2123a30b7 (patch)
treefa07314f184aa43b9432401efd9ef9e0a1366b81
parenta4021741f2f6577e99c3abc1d7663bf5338b287a (diff)
downloadaur-71ee045f9e36e0f3c411e5750af9b9c2123a30b7.tar.gz
v1.12
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27f425c5920a..85f9cf3fe42f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = katrain
pkgdesc = A tool for analyzing and playing go with AI feedback from KataGo.
- pkgver = 1.11.2
+ pkgver = 1.12
pkgrel = 1
url = https://github.com/sanderland/katrain
arch = i686
@@ -22,7 +22,7 @@ pkgbase = katrain
depends = python-urllib3
depends = python-numpy
depends = libzip
- source = https://github.com/sanderland/katrain/archive/v1.11.2fixes-for-osx.tar.gz
- sha256sums = 3fcbd1a23bda9c1558fcf0ef1728496632d67c60c120ea2fd6d04a13a6cf6aed
+ source = https://github.com/sanderland/katrain/archive/v1.12.tar.gz
+ sha256sums = 7641fed489593bbecc81fc5ee7fca3b7344841a724ce2a411248ab23d24e3dd4
pkgname = katrain
diff --git a/PKGBUILD b/PKGBUILD
index 21fa0d5dbef6..5a40a75e97a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: algebro <algebro at tuta dot io>
pkgname=katrain
-pkgver=1.11.2
+pkgver=1.12
pkgrel=1
pkgdesc="A tool for analyzing and playing go with AI feedback from KataGo."
arch=('i686' 'x86_64')
@@ -10,15 +10,15 @@ license=('MIT')
depends=('python' 'python-certifi' 'python-chardet' 'cython' 'python-dataclasses'
'python-docutils' 'python-idna' 'python-kivy>=2.0.0' 'python-kivymd' 'python-pillow'
'python-pygame' 'python-pygments' 'python-requests' 'python-urllib3' 'python-numpy' 'libzip')
-source=("https://github.com/sanderland/${pkgname}/archive/v${pkgver}fixes-for-osx.tar.gz")
-sha256sums=('3fcbd1a23bda9c1558fcf0ef1728496632d67c60c120ea2fd6d04a13a6cf6aed')
+source=("https://github.com/sanderland/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('7641fed489593bbecc81fc5ee7fca3b7344841a724ce2a411248ab23d24e3dd4')
build() {
- cd "$srcdir/$pkgname-$pkgver"fixes-for-osx
+ cd "$srcdir/$pkgname-$pkgver"
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"fixes-for-osx
+ cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}