summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralgebro2022-07-18 15:09:54 -0400
committeralgebro2022-07-18 15:09:54 -0400
commita4021741f2f6577e99c3abc1d7663bf5338b287a (patch)
tree03e8370aa85a562cf08fa4582768bd2d0480527c
parent1a9f8628d5dfc870155240da6ea9e21d475cab67 (diff)
downloadaur-a4021741f2f6577e99c3abc1d7663bf5338b287a.tar.gz
v1.11.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cab6c2c536a..27f425c5920a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = katrain
pkgdesc = A tool for analyzing and playing go with AI feedback from KataGo.
- pkgver = 1.11.1
+ pkgver = 1.11.2
pkgrel = 1
url = https://github.com/sanderland/katrain
arch = i686
@@ -20,8 +20,9 @@ pkgbase = katrain
depends = python-pygments
depends = python-requests
depends = python-urllib3
+ depends = python-numpy
depends = libzip
- source = https://github.com/sanderland/katrain/archive/v1.11.1.tar.gz
- sha256sums = f2a75ec9d1ebac45d797a3d431bf568d384ecf75a9fb56f864c909f355afeccc
+ source = https://github.com/sanderland/katrain/archive/v1.11.2fixes-for-osx.tar.gz
+ sha256sums = 3fcbd1a23bda9c1558fcf0ef1728496632d67c60c120ea2fd6d04a13a6cf6aed
pkgname = katrain
diff --git a/PKGBUILD b/PKGBUILD
index 28136d9bb9a6..21fa0d5dbef6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: algebro <algebro at tuta dot io>
pkgname=katrain
-pkgver=1.11.1
+pkgver=1.11.2
pkgrel=1
pkgdesc="A tool for analyzing and playing go with AI feedback from KataGo."
arch=('i686' 'x86_64')
@@ -9,16 +9,16 @@ url="https://github.com/sanderland/katrain"
license=('MIT')
depends=('python' 'python-certifi' 'python-chardet' 'cython' 'python-dataclasses'
'python-docutils' 'python-idna' 'python-kivy>=2.0.0' 'python-kivymd' 'python-pillow'
-'python-pygame' 'python-pygments' 'python-requests' 'python-urllib3' 'libzip')
-source=("https://github.com/sanderland/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('f2a75ec9d1ebac45d797a3d431bf568d384ecf75a9fb56f864c909f355afeccc')
+'python-pygame' 'python-pygments' 'python-requests' 'python-urllib3' 'python-numpy' 'libzip')
+source=("https://github.com/sanderland/${pkgname}/archive/v${pkgver}fixes-for-osx.tar.gz")
+sha256sums=('3fcbd1a23bda9c1558fcf0ef1728496632d67c60c120ea2fd6d04a13a6cf6aed')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"fixes-for-osx
python setup.py build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"fixes-for-osx
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}