summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2019-01-24 22:56:54 +0100
committerNarrat2019-01-24 22:56:54 +0100
commit6ff2ad444216e077523d48ddff0fb52a3cb3ce52 (patch)
treef30f7fcd6c62ca71aa58393416cd85232d2bd009
parent5db3f56648d4981f940d5efc0e91b368b3c5bf5b (diff)
downloadaur-6ff2ad444216e077523d48ddff0fb52a3cb3ce52.tar.gz
katriawm: Adjust build process
SolarAquarion made a note about the missing man pages. Looking in the generated package the issue was more grave. The whole PREFIX thing while invoking make didn't work apparently, as the stuff was installed to /usr/local/ Switched to a patch file which adjusts the config.mk which gets sourced by the Makefile.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
-rw-r--r--set_prefix.patch12
3 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aeb9ff0d6242..5a2961985cf3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = katriawm
pkgdesc = A non-reparenting, dynamic window manager for X11 with decorations
pkgver = 18.09
- pkgrel = 1
+ pkgrel = 2
url = https://www.uninformativ.de/git/katriawm/file/README.html
arch = i686
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = katriawm
depends = libxft
depends = libxrandr
source = git+https://www.uninformativ.de/git/katriawm.git#tag=v18.09
+ source = set_prefix.patch
sha256sums = SKIP
+ sha256sums = a9de73fa43affa7c32d0f678c21eb30aa9173d9e51eb8e170a0389db82f3bf8c
pkgname = katriawm
diff --git a/PKGBUILD b/PKGBUILD
index 80a76576856e..fb5cc0172d5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,24 @@
pkgname=katriawm
pkgver=18.09
-pkgrel=1
+pkgrel=2
pkgdesc="A non-reparenting, dynamic window manager for X11 with decorations"
arch=("i686" "x86_64")
url="https://www.uninformativ.de/git/katriawm/file/README.html"
license=("MIT")
makedepends=("git")
depends=("libx11" "libxft" "libxrandr")
-source=("git+https://www.uninformativ.de/git/katriawm.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("git+https://www.uninformativ.de/git/katriawm.git#tag=v${pkgver}"
+ "set_prefix.patch")
+sha256sums=('SKIP'
+ 'a9de73fa43affa7c32d0f678c21eb30aa9173d9e51eb8e170a0389db82f3bf8c')
+
prepare() {
- cd "${srcdir}/${pkgname}/src"
+ cd "${pkgname}/src"
+
+ # Set prefix
+ patch -Np2 -i "${srcdir}/set_prefix.patch"
# Read custom config headers from $XDG_CONFIG_HOME/katria{wm,bi}-config.h
@@ -32,13 +38,13 @@ prepare() {
}
build() {
- cd "${srcdir}/${pkgname}/src"
- make PREFIX=/usr
+ cd "${pkgname}/src"
+ make
}
package() {
- cd "${srcdir}/${pkgname}/src"
- make DESTDIR=${pkgdir} PREFIX=/usr MANPREFIX=/usr/share/man install
+ cd "${pkgname}/src"
+ make DESTDIR=${pkgdir} install
install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 ../README "${pkgdir}/usr/share/doc/${pkgname}/README"
}
diff --git a/set_prefix.patch b/set_prefix.patch
new file mode 100644
index 000000000000..fa52acefa1ae
--- /dev/null
+++ b/set_prefix.patch
@@ -0,0 +1,12 @@
+--- katriawm/src/config.mk
++++ katriawm/src/config.mk
+@@ -6,7 +6,7 @@
+ INSTALL_PROGRAM = $(INSTALL)
+ INSTALL_DATA = $(INSTALL) -m 644
+
+-prefix = /usr/local
++prefix = /usr
+ exec_prefix = $(prefix)
+ bindir = $(exec_prefix)/bin
+ datarootdir = $(prefix)/share
+