summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThorsten Wißmann2017-12-13 14:34:13 +0100
committerThorsten Wißmann2017-12-13 14:34:13 +0100
commitb700e974ccbb33f438dd8669a7f6ed5553d6dbe2 (patch)
tree75b039454abee20f6f70956b318c74b343eedf3f
downloadaur-b700e974ccbb33f438dd8669a7f6ed5553d6dbe2.tar.gz
Add PKGBUILD
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD25
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b0cce2d6618
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Wed Dec 13 13:33:44 UTC 2017
+pkgbase = kattis-problemtools
+ pkgdesc = Tools to manage problem packages using the Kattis problem package format
+ pkgver = v1.20170420
+ pkgrel = 1
+ url = https://github.com/Kattis/problemtools
+ arch = any
+ license = MIT
+ depends = python2
+ source = git+https://github.com/Kattis/problemtools
+ md5sums = SKIP
+
+pkgname = kattis-problemtools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..596cff8837a0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+.*.swp
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..485a296a71d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Thorsten Wißmann <edu@thorsten-wissmann.de>
+pkgname=kattis-problemtools
+pkgver=v1.20170420
+pkgrel=1
+pkgdesc="Tools to manage problem packages using the Kattis problem package format"
+arch=('any')
+url="https://github.com/Kattis/problemtools"
+license=('MIT')
+depends=('python2')
+builddepends=('python2-setuptools')
+source=("git+https://github.com/Kattis/problemtools")
+fragment=v1.20170420
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir"/problemtools
+ pwd
+ make || return 1
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$srcdir"/problemtools
+ python2 setup.py install --prefix /usr --root="$pkgdir" || return 1
+}