summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipe Nascimento2023-08-14 18:40:46 -0300
committerFilipe Nascimento2023-08-14 18:40:46 -0300
commitb6759be245b72c6912d99a296edece2590afad6d (patch)
tree918bf7783bde66c8a50c1b027ca65a7dbded72a9
parent4867cba2a6dbda875c8c71d2579b0730ea3afaa6 (diff)
downloadaur-kb.tar.gz
upgpkg: kb 0.1.7-2
add python-colored patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--python-colored.patch11
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca218eb2880a..2f21e52b5d02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kb
pkgdesc = A command line minimalist knowledge base manager
pkgver = 0.1.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gnebbia/kb
arch = any
license = GPL3
@@ -14,6 +14,8 @@ pkgbase = kb
conflicts = python-kb
replaces = python-kb
source = https://files.pythonhosted.org/packages/source/k/kb-manager/kb-manager-0.1.7.tar.gz
+ source = python-colored.patch
sha256sums = 4c2919d6c3441ae69d9ce8ee86b79f64cc27ba928ef57cf8fa8a0ac5fc8683da
+ sha256sums = e7461e91f51e87f6dce0d4a8e08438b286e1e6325519d122dbaf4255ff9d5690
pkgname = kb
diff --git a/PKGBUILD b/PKGBUILD
index 995abc09309c..e4dcb153b404 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=kb
_module=kb-manager
pkgver=0.1.7
-pkgrel=1
+pkgrel=2
pkgdesc="A command line minimalist knowledge base manager"
arch=('any')
url="https://github.com/gnebbia/kb"
@@ -13,8 +13,15 @@ depends=('python-attrs' 'python-colored' 'python-gitpython' 'python-setuptools'
checkdepends=('python-pytest-cov')
conflicts=("python-kb")
replaces=("python-kb")
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('4c2919d6c3441ae69d9ce8ee86b79f64cc27ba928ef57cf8fa8a0ac5fc8683da')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz"
+ "python-colored.patch")
+sha256sums=('4c2919d6c3441ae69d9ce8ee86b79f64cc27ba928ef57cf8fa8a0ac5fc8683da'
+ 'e7461e91f51e87f6dce0d4a8e08438b286e1e6325519d122dbaf4255ff9d5690')
+
+prepare() {
+ cd ${_module}-${pkgver}
+ patch -p1 < ../python-colored.patch
+}
build() {
cd ${_module}-${pkgver}
diff --git a/python-colored.patch b/python-colored.patch
new file mode 100644
index 000000000000..b2546cd3fa6c
--- /dev/null
+++ b/python-colored.patch
@@ -0,0 +1,11 @@
+diff --git a/kb/printer/style.py b/kb/printer/style.py
+index e0fd752..2bc7bf5 100644
+--- a/kb/printer/style.py
++++ b/kb/printer/style.py
+@@ -17,5 +17,5 @@ from kb.entities.artifact import Artifact
+
+ ALT_BGROUND = styler.set_bg('#303030')
+ BOLD = styler.set_style('bold')
+-UND = styler.set_style('underlined')
++UND = styler.set_style('underline')
+ RESET = styler.reset()