summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Isakov2023-06-14 19:52:58 +0600
committerKirill Isakov2023-06-14 19:53:15 +0600
commitcdcd15b68d8329879f89956c2981b558395c35b4 (patch)
treee24584e88117176ea348a06800ca9dedb162f44e
downloadaur-cdcd15b68d8329879f89956c2981b558395c35b4.tar.gz
upgpkg: kbd-audio 2022.05.03-1
upstream release upgpkg: kbd-audio 3-1 upstream release Initial upload: kbd-audio 3-1 add kbd-audio
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD53
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a356f6f0061
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kbd-audio
+ pkgdesc = Acoustic keyboard eavesdropping
+ pkgver = 2022.05.03
+ pkgrel = 1
+ url = https://github.com/ggerganov/kbd-audio
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = cmake
+ depends = sdl2
+ depends = fftw
+ depends = libglvnd
+ source = kbd-audio-2022.05.03::git+https://github.com/ggerganov/kbd-audio.git#tag=keytap3
+ sha256sums = SKIP
+
+pkgname = kbd-audio
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10f2f789f527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: tarball <bootctl@gmail.com>
+
+pkgname=kbd-audio
+pkgver=2022.05.03
+pkgrel=1
+pkgdesc='Acoustic keyboard eavesdropping'
+arch=(i686 x86_64 aarch64)
+url='https://github.com/ggerganov/kbd-audio'
+license=(MIT)
+depends=(sdl2 fftw libglvnd)
+makedepends=(cmake)
+source=("$pkgname-$pkgver::git+$url.git#tag=keytap3")
+sha256sums=('SKIP')
+
+prepare() {
+ cd $pkgname-$pkgver
+ git submodule update --init
+}
+
+build() {
+ cmake -B build -S "$srcdir/$pkgname-$pkgver" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ cmake --build build
+}
+
+package() {
+ local bins=(
+ compress-n-grams
+ key-detector
+ keytap
+ keytap-gui
+ keytap2
+ keytap2-gui
+ keytap3
+ keytap3-app
+ keytap3-gui
+ play
+ play-full
+ record
+ record-full
+ view-full-gui
+ view-gui
+ )
+
+ for bin in "${bins[@]}"; do
+ install -Dm755 "build/$bin" "$pkgdir/usr/bin/kbd-$bin"
+ done
+
+ install -Dm755 "$srcdir/$pkgname-$pkgver/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}