summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip K. Gisslow2021-08-02 19:34:04 +0200
committerPhilip K. Gisslow2021-08-02 19:34:04 +0200
commita2dc7687243af6b2653f7bd9f07149e40a51ba19 (patch)
tree35f0ae5dd5428560c39958aba6e4ebab50f17100
downloadaur-a2dc7687243af6b2653f7bd9f07149e40a51ba19.tar.gz
Initial version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ceda5f76047c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kbd_stats-git
+ pkgdesc = A tool to log/measure keyboard metrics
+ pkgver = 0.1.0.31.ge9baaad
+ pkgrel = 1
+ url = https://github.com/ripxorip/kbd_stats
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = aarch64
+ license = MIT
+ license = Apache
+ makedepends = rust
+ makedepends = cargo
+ makedepends = git
+ provides = kbd_stats
+ conflicts = kbd_stats
+ source = kbd_stats::git+https://github.com/ripxorip/kbd_stats.git
+ sha256sums = SKIP
+
+pkgname = kbd_stats-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03ed45be35bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Philip K Gisslow <ripxorip@gmail.com>
+
+pkgname="kbd_stats-git"
+_pkgname="kbd_stats"
+pkgver=0.1.0.31.ge9baaad
+pkgrel=1
+pkgdesc="A tool to log/measure keyboard metrics"
+arch=("i686" "x86_64" "arm" "aarch64")
+url="https://github.com/ripxorip/kbd_stats"
+license=("MIT" "Apache")
+depends=()
+makedepends=("rust" "cargo" "git")
+provides=("kbd_stats")
+conflicts=("kbd_stats")
+source=("$_pkgname::git+https://github.com/ripxorip/kbd_stats.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ cargo build --release --locked
+}
+
+check() {
+ cd $_pkgname
+ cargo test --release --locked
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 target/release/$_pkgname "$pkgdir/usr/bin/$_pkgname"
+}