summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Burykin2019-07-10 15:52:20 +0300
committerKonstantin Burykin2019-07-10 15:52:20 +0300
commit1fc8f9c53499f4df67f2762987bd38add064cdc3 (patch)
tree533566a1226160b2dd0f66255272b10620e42553
downloadaur-1fc8f9c53499f4df67f2762987bd38add064cdc3.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.drone.yml28
-rw-r--r--.gitignore4
-rw-r--r--LICENSE-AUR21
-rw-r--r--PKGBUILD37
5 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6c48f70f0a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kbdlightx1-bin
+ pkgdesc = Keyboard backlight switcher for Thinkpad X1 Carbon 5gen
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/burkostya/kbdlight
+ arch = x86_64
+ license = MIT
+ depends = upower
+ provides = kbdlight
+ conflicts = kbdlight
+ options = strip
+ source = https://github.com/burkostya/kbdlight/releases/download/v0.1.2/kbdlight
+ source = https://raw.githubusercontent.com/burkostya/kbdlight/master/LICENSE
+ sha512sums = c101f9c0c83287e501eeebbf1c4a689bfa6cb5afc694136223c32a90a67745ce10047206f888905e9ca1da692821631f305f643435101ba3ddfe2a89dd5ea0c1
+ sha512sums = eef3e40af37c4846476c7ecb687f1ee129612acec95d80119ad74179948dd1add2217a9701617eba68a399ce7744ca1539f96d31e7a59d48df7fc8a57b24286b
+
+pkgname = kbdlightx1-bin
+
diff --git a/.drone.yml b/.drone.yml
new file mode 100644
index 000000000000..bb48fcec3b18
--- /dev/null
+++ b/.drone.yml
@@ -0,0 +1,28 @@
+kind: pipeline
+name: default
+
+steps:
+- name: build
+ image: archlinux/base
+ commands:
+ - mkdir build
+ - chgrp nobody build
+ - chmod g+ws build
+ - setfacl -m u::rwx,g::rwx build
+ - setfacl -d --set u::rwx,g::rwx,o::r build
+ - ls
+ - pacman -Sy --noconfirm binutils sudo grep fakeroot file
+ - pacman -S --noconfirm upower
+ - mv PKGBUILD build/
+ - pushd build
+ - sudo -u nobody makepkg -c
+ - ls -la
+ - popd
+ - mv build/kbdlightx1-* ./
+ - mv build/PKGBUILD ./
+- name: test
+ image: archlinux/base
+ commands:
+ - pacman -Sy --noconfirm namcap grep
+ - namcap PKGBUILD
+ - namcap kbdlightx1-* \ No newline at end of file
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..533f6d3b2a9e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+kbdlight*
+LICENSE \ No newline at end of file
diff --git a/LICENSE-AUR b/LICENSE-AUR
new file mode 100644
index 000000000000..9056a6ef1590
--- /dev/null
+++ b/LICENSE-AUR
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2019 Burykin Konstantin
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9cb1796d642
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Konstantin Burykin <burkostya@gmail.com>
+pkgname=kbdlightx1-bin
+_binname=kbdlight
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Keyboard backlight switcher for Thinkpad X1 Carbon 5gen"
+arch=('x86_64')
+url="https://github.com/burkostya/kbdlight"
+license=('MIT')
+groups=()
+depends=('upower')
+provides=("$_binname")
+conflicts=("$_binname")
+backup=()
+options=('strip')
+install=
+source=(
+ "https://github.com/burkostya/$_binname/releases/download/v$pkgver/$_binname"
+ "https://raw.githubusercontent.com/burkostya/$_binname/master/LICENSE"
+)
+noextract=()
+sha512sums=(
+ 'c101f9c0c83287e501eeebbf1c4a689bfa6cb5afc694136223c32a90a67745ce10047206f888905e9ca1da692821631f305f643435101ba3ddfe2a89dd5ea0c1'
+ 'eef3e40af37c4846476c7ecb687f1ee129612acec95d80119ad74179948dd1add2217a9701617eba68a399ce7744ca1539f96d31e7a59d48df7fc8a57b24286b'
+)
+
+build() {
+ chmod +x "$srcdir/$_binname"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ cp "$srcdir/$_binname" "$pkgdir/usr/bin/$_binname"
+
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ cp "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
+}