summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-10-06 20:17:23 +0300
committerorhun2020-10-06 20:17:23 +0300
commit900b5cd12033b774d590fe740ef02ce64e199176 (patch)
treee3a7558a2c241b27f6a92fab33f063c207f41236
downloadaur-900b5cd12033b774d590fe740ef02ce64e199176.tar.gz
Initial upload: kbs2 0.1.5-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..140d0cdbc2be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kbs2
+ pkgdesc = A secret manager backed by age
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/woodruffw/kbs2
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ makedepends = python
+ depends = libx11
+ source = kbs2-0.1.5.tar.gz::https://github.com/woodruffw/kbs2/archive/v0.1.5.tar.gz
+ sha512sums = SKIP
+
+pkgname = kbs2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bac23d5bd64a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=kbs2
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="A secret manager backed by age"
+arch=('x86_64')
+url="https://github.com/woodruffw/kbs2"
+license=('MIT')
+depends=('libx11')
+makedepends=('cargo' 'python')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked --all-features
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}