summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-12-12 14:53:57 +0300
committerorhun2020-12-12 14:53:57 +0300
commit70469c9f0d33133c2be6d1d5382c33199586214c (patch)
tree9c5f7dcf0748b11430eef5d3f5b8f5287a26270a
parentcd9594a98b453fe1c16a222b45fd711d794f984e (diff)
downloadaur-70469c9f0d33133c2be6d1d5382c33199586214c.tar.gz
upgpkg: kbs2-bin 0.2.4-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bf2aea07738..6f711b07b123 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = kbs2-bin
pkgdesc = A secret manager backed by age
- pkgver = 0.2.2
+ pkgver = 0.2.4
pkgrel = 1
url = https://github.com/woodruffw/kbs2
arch = x86_64
license = MIT
provides = kbs2
conflicts = kbs2
- source_x86_64 = https://github.com/woodruffw/kbs2/releases/download/v0.2.2/kbs2-linux-v0.2.2.tar.gz
- sha256sums_x86_64 = 58480a61d5a04523f186d51954fdfc449ba729eeb2eb228e9303a4eba1d6c727
+ source_x86_64 = https://github.com/woodruffw/kbs2/releases/download/v0.2.4/kbs2-linux-v0.2.4.tar.gz
+ sha256sums_x86_64 = f4c7bea4e49fa9382b849c20037c7f3a71a2ba9e0d94a69e33c87bc79f7b2140
pkgname = kbs2-bin
diff --git a/PKGBUILD b/PKGBUILD
index f2647b69d449..d0092044cd90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=kbs2-bin
-pkgver=0.2.2
+pkgver=0.2.4
pkgrel=1
pkgdesc="A secret manager backed by age"
arch=('x86_64')
@@ -11,13 +11,13 @@ license=('MIT')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}")
source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}-linux-v${pkgver}.tar.gz")
-sha256sums_x86_64=('58480a61d5a04523f186d51954fdfc449ba729eeb2eb228e9303a4eba1d6c727')
+sha256sums_x86_64=('f4c7bea4e49fa9382b849c20037c7f3a71a2ba9e0d94a69e33c87bc79f7b2140')
package() {
install -Dm 755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- "${pkgname%-bin}" --completions bash | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-bin}"
- "${pkgname%-bin}" --completions fish | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/fish/completions/${pkgname%-bin}.fish"
- "${pkgname%-bin}" --completions zsh | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_${pkgname%-bin}"
+ "./${pkgname%-bin}" --completions bash | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-bin}"
+ "./${pkgname%-bin}" --completions fish | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/fish/completions/${pkgname%-bin}.fish"
+ "./${pkgname%-bin}" --completions zsh | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_${pkgname%-bin}"
}