summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLEVAI Daniel2024-03-08 22:52:59 +0100
committerLEVAI Daniel2024-03-08 22:52:59 +0100
commiteb040e0430eff08f01caaae7640867beabe8362d (patch)
treeeb88af1f7f41175547a87b90e03701dc1c5387ac
downloadaur-eb040e0430eff08f01caaae7640867beabe8362d.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac4b0b530cc4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kc
+ pkgdesc = console-based password manager - YubiKey, scrypt, PCRE and readline support
+ pkgver = 2.5.3
+ pkgrel = 1
+ url = https://github.com/levaidaniel/kc
+ arch = any
+ license = BSD-2-Clause
+ depends = libbsd>=0.2.0
+ depends = libxml2>=2.6.0
+ depends = openssl>=1.1.1
+ depends = yubikey-personalization>=1.20.0
+ depends = yubico-c>=1.13
+ depends = libscrypt>=1.14
+ depends = pcre>=8.12
+ depends = readline
+ conflicts = kc
+ source = kc-2.5.3.tar.gz::https://github.com/levaidaniel/kc/archive/refs/tags/2.5.3.tar.gz
+ sha256sums = 593db34bf53ad9197c3ac1ffc3742dfc03a784862f0a5fadeda6b6d2ad287539
+
+pkgname = kc-full
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..828006a325ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.gz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3705549a3df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Levai, Daniel <leva at ecentrum.hu>
+
+pkgbase='kc'
+pkgname='kc-full'
+pkgver=2.5.3
+pkgrel=1
+pkgdesc="console-based password manager - YubiKey, scrypt, PCRE and readline support"
+arch=('any')
+url="https://github.com/levaidaniel/kc"
+license=('BSD-2-Clause')
+conflicts=('kc')
+depends=('libbsd>=0.2.0'
+'libxml2>=2.6.0'
+'openssl>=1.1.1'
+'yubikey-personalization>=1.20.0'
+'yubico-c>=1.13'
+'libscrypt>=1.14'
+'pcre>=8.12'
+'readline'
+)
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/levaidaniel/${pkgbase}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('593db34bf53ad9197c3ac1ffc3742dfc03a784862f0a5fadeda6b6d2ad287539')
+
+
+build() {
+ cd "${pkgbase}-${pkgver}"
+ make HAVE_PCRE=y HAVE_LIBSCRYPT=y HAVE_YUBIKEY=y -f Makefile.linux
+}
+
+package() {
+ cd "${pkgbase}-${pkgver}"
+ make HAVE_PCRE=y HAVE_LIBSCRYPT=y HAVE_YUBIKEY=y -f Makefile.linux install DESTDIR="${pkgdir}/" PREFIX=/usr
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 'Changelog.md' -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -m644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}/"
+}