summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Jost2022-06-09 14:35:07 +0200
committerThomas Jost2022-06-09 14:35:07 +0200
commit694c020ccbed9eeba26489f6aa876ebaee8660cc (patch)
tree2013e1950cf945bd643fb9188d87da62764a0b16
parent58d177d31ef4b127300135d1146dc708c7cffbbd (diff)
downloadaur-694c020ccbed9eeba26489f6aa876ebaee8660cc.tar.gz
Add support for python-slugify >= 6.0.0
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD8
-rw-r--r--kcc-slugify6.patch11
4 files changed, 25 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 662bbe536045..fb3a9ce9725c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kcc
pkgdesc = Kindle Comic Converter converts comic files or folders to ePub or Panel View MOBI
pkgver = 5.5.2
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/ciromattia/kcc
arch = any
license = ISC
@@ -11,17 +11,20 @@ pkgbase = kcc
depends = python-psutil>=5.0.0
depends = python-pyqt5>=5.6.0
depends = python-raven>=6.0.0
- depends = python-slugify>=1.2.1
+ depends = python-slugify>=6.0.0
optdepends = kindlegen>=2.9: for .mobi generation
optdepends = p7zip: for zip/CBZ, rar/CBZ, 7z/CB7 support
source = kindlecomicconverter.desktop
source = kcc-py310.patch
+ source = kcc-slugify6.patch
source = https://github.com/ciromattia/kcc/archive/5.5.2.tar.gz
md5sums = f25b30fbc1bc1db491173215fe411789
md5sums = 4f12019d3efda060bf45bd516831a346
+ md5sums = 9701c427a46aa9d9a2e34062ee0891b1
md5sums = 483f06333bbae8e0f4c28252487b9d97
sha256sums = 3502c38d756f5a812ac06f63fe25e062d8720f620ffd7d25641e6accef9fdd9f
sha256sums = 72b22f6fea6a7727ef8671e0386291c7d6946f4e8046dc037d46bfd8c3621138
+ sha256sums = 43236d6351d95db1405e0f9f2b32e531248886afc3b4c110511d32b7ec1241dd
sha256sums = 7b45fcdf0149bea36e8c738e76031790c8c235c777047001279698a526be892b
pkgname = kcc
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6803660e373a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src
+/pkg
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 8827d62037da..d61f65cc6d7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Thomas Jost <schnouki@schnouki.net>
pkgname=kcc
pkgver=5.5.2
-pkgrel=5
+pkgrel=6
pkgdesc="Kindle Comic Converter converts comic files or folders to ePub or Panel View MOBI"
arch=(any)
url="https://github.com/ciromattia/kcc"
license=('ISC')
-depends=('python>=3.10' 'python-pillow>=9.0.0' 'python-psutil>=5.0.0' 'python-pyqt5>=5.6.0' 'python-raven>=6.0.0' 'python-slugify>=1.2.1')
+depends=('python>=3.10' 'python-pillow>=9.0.0' 'python-psutil>=5.0.0' 'python-pyqt5>=5.6.0' 'python-raven>=6.0.0' 'python-slugify>=6.0.0')
optdepends=(
'kindlegen>=2.9: for .mobi generation'
'p7zip: for zip/CBZ, rar/CBZ, 7z/CB7 support'
@@ -14,17 +14,21 @@ optdepends=(
makedepends=('python-setuptools')
source=(kindlecomicconverter.desktop
kcc-py310.patch
+ kcc-slugify6.patch
https://github.com/ciromattia/$pkgname/archive/$pkgver.tar.gz)
md5sums=('f25b30fbc1bc1db491173215fe411789'
'4f12019d3efda060bf45bd516831a346'
+ '9701c427a46aa9d9a2e34062ee0891b1'
'483f06333bbae8e0f4c28252487b9d97')
sha256sums=('3502c38d756f5a812ac06f63fe25e062d8720f620ffd7d25641e6accef9fdd9f'
'72b22f6fea6a7727ef8671e0386291c7d6946f4e8046dc037d46bfd8c3621138'
+ '43236d6351d95db1405e0f9f2b32e531248886afc3b4c110511d32b7ec1241dd'
'7b45fcdf0149bea36e8c738e76031790c8c235c777047001279698a526be892b')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -p0 < "$srcdir"/kcc-py310.patch
+ patch -p0 < "$srcdir"/kcc-slugify6.patch
}
build() {
diff --git a/kcc-slugify6.patch b/kcc-slugify6.patch
new file mode 100644
index 000000000000..ade8d3df787c
--- /dev/null
+++ b/kcc-slugify6.patch
@@ -0,0 +1,11 @@
+--- kindlecomicconverter/shared.py.orig 2022-06-09 14:31:52.779848604 +0200
++++ kindlecomicconverter/shared.py 2022-06-09 14:31:56.995860466 +0200
+@@ -117,7 +117,7 @@
+ except ImportError:
+ missing.append('psutil 5.0.0+')
+ try:
+- from slugify import __version__ as slugifyVersion
++ from slugify.__version__ import __version__ as slugifyVersion
+ if StrictVersion('1.2.1') > StrictVersion(slugifyVersion):
+ missing.append('python-slugify 1.2.1+')
+ except ImportError: