summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilhelm Schuster2016-11-01 09:44:07 +0100
committerWilhelm Schuster2016-11-01 09:44:07 +0100
commit0a24c116ca88ca20876b3f598760103402614017 (patch)
treeee88036d6a580896b7f391897dd74b0031a19f52
parentf233edb6b09b3066972f464b94c2e60ad309ab97 (diff)
downloadaur-0a24c116ca88ca20876b3f598760103402614017.tar.gz
Update to 0.9.1
Additionally, fix kutil_openlog().
-rw-r--r--PKGBUILD11
-rw-r--r--fix-kutil_openlog.patch24
2 files changed, 33 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2fa41b4553d9..7f6bdbe6ff8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Wilhelm Schuster <wilhelm [aT] wilhelm [.] re>
pkgname=kcgi
-pkgver=0.9.0
+pkgver=0.9.1
pkgrel=1
pkgdesc="Minimal CGI and FastCGI library"
arch=('i686' 'x86_64')
@@ -8,10 +8,17 @@ url="http://kristaps.bsd.lv/kcgi/"
license=('custom')
depends=('glibc')
source=("https://kristaps.bsd.lv/kcgi/snapshots/$pkgname-$pkgver.tgz"
+ "fix-kutil_openlog.patch"
"LICENSE")
-sha512sums=('b8e0c2acda0afa872a765c0477a30ee7f9ba365bf6b11de4a11da8d6542ffed4f138212ea365acab9b243701e53f826d9652cbbd1acd12b174997ea97b3009e5'
+sha512sums=('4d6f823fa4cbe47f9806ea70978e23cef6155c7f961ea9968083d6a021dc31b2386a23e9681cf60947f2caf1f9300e9f0c4ad1baf032f9080140d21d67ac2fe0'
+ 'c4bc67df753211e0f7c7e0296dfafafa011a50e08125e779ef88bcd8517e07406d78de9bf260fa503576eeae0e98e4648b475a4a8e9a80737f5ac059d42096f5'
'b040c157fe8b95a41a0375d2cd3cc4e6406a988ed5f337b0c6dd15f1ea08344196018a5c2353c2acfbde7858ca5e0f2bf00d1cc4890661effadf39e239a95520')
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i "${srcdir}/fix-kutil_openlog.patch"
+}
+
build() {
cd $pkgname-$pkgver
diff --git a/fix-kutil_openlog.patch b/fix-kutil_openlog.patch
new file mode 100644
index 000000000000..e9b23749d911
--- /dev/null
+++ b/fix-kutil_openlog.patch
@@ -0,0 +1,24 @@
+From da456618e693be27ba6ddf56cef579895fa1d9c5 Mon Sep 17 00:00:00 2001
+From: kristaps <>
+Date: Sun, 30 Oct 2016 19:25:17 +0000
+Subject: [PATCH] Portability: on Linux, setlinebuf doesn't wrap directly
+ around setvbuf. Noted on https://github.com/kristapsdz/kcgi/pull/10 --
+ thanks!
+
+---
+ logging.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/logging.c b/logging.c
+index f06e7a6..831b935 100644
+--- a/logging.c
++++ b/logging.c
+@@ -103,7 +103,7 @@ kutil_openlog(const char *file)
+
+ if (NULL != file && NULL == freopen(file, "a", stderr))
+ return(0);
+- return(EOF != setlinebuf(stderr));
++ return(EOF != setvbuf(stderr, NULL, _IOLBF, 0));
+ }
+
+ void