summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-16 17:19:47 +0200
committersl1pkn072015-06-16 17:19:47 +0200
commit9facfc1370196a8965947dc92e16b5438ebf22c9 (patch)
tree54d7d085671e03534c6ac2a7913a60ae4bcbbf04
downloadaur-9facfc1370196a8965947dc92e16b5438ebf22c9.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--kcharselect-git.install12
4 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7009028f8b21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kcharselect-git
+ pkgdesc = Character Selector. (GIT version)
+ pkgver = 1.12.r295.276f21d
+ pkgrel = 1
+ url = https://www.kde.org/applications/utilities/kcharselect
+ install = kcharselect-git.install
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ license = FDL
+ makedepends = extra-cmake-modules
+ makedepends = kdoctools
+ makedepends = git
+ depends = kxmlgui
+ provides = kcharselect
+ conflicts = kcharselect
+ conflicts = kdeutils-kcharselect
+ source = git://anongit.kde.org/kcharselect.git
+ sha1sums = SKIP
+
+pkgname = kcharselect-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..084a272e6144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!kcharselect-git.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1aba6a4f6c6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+pkgname=kcharselect-git
+pkgver=1.12.r295.276f21d
+pkgrel=1
+pkgdesc="Character Selector. (GIT version)"
+url='https://www.kde.org/applications/utilities/kcharselect'
+arch=('x86_64')
+license=('GPL' 'LGPL' 'FDL')
+depends=('kxmlgui')
+makedepends=('extra-cmake-modules' 'kdoctools' 'git')
+conflicts=('kcharselect' 'kdeutils-kcharselect')
+provides=('kcharselect')
+source=("git://anongit.kde.org/kcharselect.git")
+sha1sums=('SKIP')
+install=kcharselect-git.install
+
+pkgver() {
+ cd kcharselect
+ _ver="$(cat main.cc | grep -m1 'KDE character selection utility' | cut -d '"' -f2)"
+ echo -e "${_ver// /.}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kcharselect \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
+ -DBUILD_TESTS=OFF
+ make
+}
+
+package() {
+ make -C build DESTDIR="${pkgdir}" install
+}
diff --git a/kcharselect-git.install b/kcharselect-git.install
new file mode 100644
index 000000000000..5c501dc49916
--- /dev/null
+++ b/kcharselect-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}