summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormnovick19882016-02-06 12:04:37 -0500
committermnovick19882016-02-06 12:04:37 -0500
commit8eb8abe36ccfe9bda5102e0c3ee5f6514698e086 (patch)
treeec60900add69a9cc9c838d3eb2a3bd4114ce747f
downloadaur-8eb8abe36ccfe9bda5102e0c3ee5f6514698e086.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e174a0d3090
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 17:04:20 UTC 2016
+pkgbase = kcm-polkit-kde-git
+ pkgdesc = Configuration for Policy Kit
+ pkgver = 160.9ad726f
+ pkgrel = 1
+ epoch = 1
+ url = https://projects.kde.org/projects/extragear/base/polkit-kde-kcmodules-1
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = git
+ depends = polkit-kde
+ provides = polkit-kde-kcmodules
+ conflicts = polkit-kde-kcmodules
+ source = git://anongit.kde.org/polkit-kde-kcmodules-1
+ md5sums = SKIP
+
+pkgname = kcm-polkit-kde-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..645935a08111
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Max Resch <resch.max@gmail.com>
+# Contributor: Ivan Shapovalov <intelfx100@gmail.com>
+#
+# COPIED FROM AUR3
+#
+
+
+pkgname=kcm-polkit-kde-git
+epoch=1
+pkgver=160.9ad726f
+pkgrel=1
+pkgdesc="Configuration for Policy Kit"
+arch=('i686' 'x86_64')
+url="https://projects.kde.org/projects/extragear/base/polkit-kde-kcmodules-1"
+license=('GPL')
+depends=('polkit-kde')
+provides=('polkit-kde-kcmodules')
+conflicts=('polkit-kde-kcmodules')
+makedepends=('cmake' 'automoc4' 'git')
+
+source=("git://anongit.kde.org/polkit-kde-kcmodules-1")
+md5sums=('SKIP')
+
+pkgver() {
+ cd polkit-kde-kcmodules-1
+
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd polkit-kde-kcmodules-1
+
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQT_QMAKE_EXECUTABLE=/usr/bin/qmake-qt4
+ make
+}
+
+package() {
+ cd polkit-kde-kcmodules-1
+
+ make DESTDIR="${pkgdir}" install
+}