summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Saveljev2015-10-13 22:30:26 +0300
committerRoman Saveljev2015-10-17 16:12:18 +0300
commit518a36310be9c341d51eb96b5f5c92cddbd7fe5e (patch)
tree4e813f730423a61ec9f2deb1ae454c4cd16c6984
parent8da91cabf717123120f64b2e64086bf14da5edc8 (diff)
downloadaur-518a36310be9c341d51eb96b5f5c92cddbd7fe5e.tar.gz
Add kconfig-config2h generic tool
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rwxr-xr-xkconfig-config2h12
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca2aaa089252..7f13432f9570 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = kconfig-frontends
pkgdesc = Out of the Linux source tree, packaging of the kconfig infrastructure, ready for use by third party projects
pkgver = 3.12.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://ymorin.is-a-geek.org/projects/kconfig-frontends
arch = x86_64
arch = i686
license = GPL
makedepends = gperf
depends = ncurses
+ depends = perl
source = http://ymorin.is-a-geek.org/download/kconfig-frontends/kconfig-frontends-3.12.0.0.tar.xz
+ source = kconfig-config2h
md5sums = b939280dcc83f8feabd87a1d5f9b00c2
+ md5sums = 6596064684b8d2bca25e8fec3e265adf
pkgname = kconfig-frontends
diff --git a/PKGBUILD b/PKGBUILD
index 07c394e08c49..b3eaa8b5d5fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Roman Saveljev <roman.saveljev@haltian.com>
pkgname=kconfig-frontends
pkgver=3.12.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Out of the Linux source tree, packaging of the kconfig infrastructure, ready for use by third party projects'
arch=('x86_64' 'i686')
url="http://ymorin.is-a-geek.org/projects/kconfig-frontends"
license=('GPL')
-depends=('ncurses')
+depends=('ncurses' 'perl')
makedepends=('gperf')
-source=("http://ymorin.is-a-geek.org/download/kconfig-frontends/$pkgname-$pkgver.tar.xz")
+source=("http://ymorin.is-a-geek.org/download/kconfig-frontends/$pkgname-$pkgver.tar.xz"
+ "kconfig-config2h")
noextract=()
-md5sums=('b939280dcc83f8feabd87a1d5f9b00c2')
+md5sums=('b939280dcc83f8feabd87a1d5f9b00c2'
+ '6596064684b8d2bca25e8fec3e265adf')
validpgpkeys=()
build() {
@@ -20,6 +22,8 @@ build() {
}
package() {
+ install -dm755 ${pkgdir}/usr/bin
+ install -m755 -t ${pkgdir}/usr/bin kconfig-config2h
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" install
}
diff --git a/kconfig-config2h b/kconfig-config2h
new file mode 100755
index 000000000000..688f9ea9c1ae
--- /dev/null
+++ b/kconfig-config2h
@@ -0,0 +1,12 @@
+#!/usr/bin/env perl
+
+use warnings;
+use strict;
+use feature 'say';
+
+foreach (<STDIN>) {
+ next if m/^#/;
+ say "#define $1" if m/^(\w+)=y$/;
+ say "#define $1 $2" if m/^(\w+)=(.+)$/;
+}
+